3

I'm trying to install the libfaudio0 that WineHQ tells me I need to add, and I don't know what to do, I don't know how to install these packages I've never done something like this before.

Here's the link to it.

closed as off-topic by Kulfy, Zanna, Soren A, andrew.46, mikewhatever May 24 at 23:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Kulfy, Zanna, Soren A, andrew.46, mikewhatever
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    For questions about Mint you can use Unix & Linux. Here is off-topic because Mint isn't an official Ubuntu variant. – GabrielaGarcia May 22 at 22:00
  • 1
    the answer askubuntu.com/a/1145491/46437 worked perfecly for ubuntu 18.04! I will try to rephrase the question to meet this site requirements :) – Aquarius Power Sep 13 at 1:42
  • 2
    I don't see any reference to Linux Mint anywhere in this question anymore. Has the question been adequately rephrased to allow it to be reopened? The answer provided by @andrew-46 was extremely helpful in my vanilla Ubuntu 19.04 installation of Wine, so I think others may benefit as well. – justathoughtor2 Sep 13 at 22:48
5

Beginning with Wine 4.5 the wine-devel packages from WineHQ require libfaudio0 as a dependency. The Wine Wiki suggests that both i386 and amd64 libfaudio0 packages should be installed and I illustrate the required steps for Ubuntu 18.04 Bionic Beaver, although similar steps should work for 18.10 and 19.04:

For Ubuntu 18.04 (and Mint 19.x!!) first download both required Debian packages:

cd ~/Desktop
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/amd64/libfaudio0_19.05-0~bionic_amd64.deb
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/libfaudio0_19.05-0~bionic_i386.deb

if the links are broken, you can still find the files from here: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ you just need to click on i386 and amd64 folders to get'em.

Next install the two files and then attend to some missing files:

cd ~/Desktop
sudo dpkg -i libfaudio0_19.05-0~bionic_amd64.deb libfaudio0_19.05-0~bionic_i386.deb
sudo apt --fix-broken install

And now you should be right to install and run the very latest versions of Wine from WineHQ!

References:

  • 1
    Please don't edit to remove distro information from the question. I talked about my opinion on this here. Then there was an awful scope debate in which some people said that if you know the issue is not distro-specific then go ahead and edit. I disagree with this, but in any case a packaging issue could always be distro-specific, I think. – Zanna May 24 at 8:16
  • 1
    @Zanna My apologies! I have read the 2 links and you have my sympathies for the stresses of this debate, my own resolve in Linux is to:"Have fun!" and some of the fun seems to have been sucked out of the world with this particular discussion. As a gesture of solidarity I will cast a close vote for this question :) – andrew.46 May 24 at 10:01
  • <3 thank you :) – Zanna May 24 at 10:12
  • marvelous answer thx!! worked perfectly for ubuntu 18.04! – Aquarius Power Sep 13 at 1:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.