20

I'm trying to install the libfaudio0 in Ubuntu 18.04. LTS and WineHQ tells me I need too add, and I don't know what to do, I don't know how to install these packages How do I install libfaudio from this repository? I have no clue how to do this.

0
38

Beginning with Wine 4.5 the wine-devel packages from WineHQ require libfaudio0 as a dependency. The Wine Wiki suggests that both i386 and amd64 libfaudio0 packages should be installed and I illustrate the required steps for Ubuntu 18.04 Bionic Beaver, although similar steps should work for 18.10 and 19.04:

For Ubuntu 18.04 first download both required Debian packages:

cd ~/Desktop
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/amd64/libfaudio0_19.07-0~bionic_amd64.deb
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/libfaudio0_19.07-0~bionic_i386.deb

if the links are broken, you can still find the files from here, you just need to open the i386 and amd64 folders to find the updated files.

Next install the two files and then attend to some missing files:

cd ~/Desktop
sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb
sudo apt --fix-broken install

And now you should be right to install and run the very latest versions of Wine from WineHQ!

References:

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.