0

I'm trying to download the AOSP from Google using repo sync. Occasionally, I receive an error similar to the following:

fatal: unable to access 'https://android.googlesource.com/platform/system/bt/': gnutls_handshake() failed: Error in the push function.

I tried the solution posted "error: gnutls_handshake() failed" when connecting to https servers. Unfortunately, it ended with openssl not functioning properly in WSL. So, I uninstalled that build of git and reinstalled sudo apt-get install git. My current git version is 2.7.4.

The error appears only occasionally, e.g. the first repo sync checked out 90% of the projects successfully. Here is a screenshot illustrating the erratic behavior of the error: enter image description here

Lastly, I am using WSL with a proxy so there is plenty of room for strange issues.

0

Found the problem, my proxy resolved to 1 of 2 IP addresses. One of them worked without issue, the other did not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.