I have a bluetooth speaker that works fine on both MacOS and Windows.

It connects fine on Kubuntu 19.04, and lists as "connected", but no sound actually comes out.

I've had this problem on Lubuntu as well, which I knows also uses elements of the KDE desktop. enter image description here


I eventually figured this out.

If you click on the "volume" icon (a speaker icon, at the bottom-right of the desktop by default in Kubuntu), there are two tabs; "Devices" and "Applications." If you click on "Applications", and then click on the sandwich icon (three bars) that opens the settings, you'll find that "Built-in analog speakers" are the default setting; you must select your Bluetooth device manually.

Would be a nice fix in the next version of Kubuntu to have a plugged-in Bluetooth device be the default, as this is the behavior we see in nearly all OS's.

enter image description here

| improve this answer | |
  • As with most things in KDE, this can be configured. System Settings>Multimedia>Audio and Video. By the way, you can also drag-and-drop applications to devices in the Audio Volume widget. – danzel May 22 '19 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.