30

I have been using Firefox on Ubuntu 18.04 for several weeks. I currently have firefox 67.0 (freshly updated). Since the update, firefox cannot connect to the internet anymore. The internet is working fine. I am writing this post from the Opera browser the I installed on Ubuntu 18.04 after the problems with Firefox.

I tried to follow the suggestions of this post. Explicitly I tried the following:

  1. Change proxy setting, in about:preferences Network Settings. I tried the options "no proxy", "Auto-detect proxy" and "Use system proxy" (the latter was the default).
  2. In about:config I set the "network.dns.disableIPv6" to TRUE
  3. In about:config I set the "network.dns.disablePrefetch" to TRUE

The issue seems firefox-specific. Opera does not give any problem. Pinging to www.google.it works fine (so no DNS problems).

I am fine using Opera, but I would also like to understand hwo to fix the issue in Firefox!

8
  • 3
    Have you tried starting Firefox with a new, blank profile?
    – Jos
    May 22, 2019 at 9:47
  • 2
    Thanks, @Jos, I followed your suggestion. With a blank profile I can regularly connect to the Internet. I will now try to move the important info to the new blank profile and see if the problem is solved while keeping all my needed info. May 22, 2019 at 9:56
  • @Jos, if you set your comment as an answer I will be happy to accept it. Just as un update, copying important information from the old profile to the new one is slightly more than a 5 minutes job (support.mozilla.org/en-US/kb/…). Also, given the risk of importing the corrupting piece when copy the info, I will rather redo all the logins and preferences (not much really). I will also keep using both Opera and Firefox for a while! May 22, 2019 at 10:10
  • 2
    @FabioMarroni I understand. You already fixed it... the hard way :-) It took some time for me to research the problem and document the easier fix. Anyway, the docs you refer to indicate "As the asker, you have a special privilege: you may accept the answer that you believe is the best solution to your problem", and for at least 9 other people it worked for them, as seen by their up votes. You can obviously decide for yourself :-)
    – heynnema
    May 28, 2019 at 14:14
  • 1
    I agree. I trust you and the opinion of 9 other people and I hope I will not need to test the reliability of your answer (i.e. I hope my profile doesn't mess up again!) May 28, 2019 at 14:53

6 Answers 6

43

The easy fix, with no profile or preferences rebuilding required...

This just renames the current Firefox cache folder. Firefox recreates this folder at next launch. The .HOLD only saves the old folder as a backup, just in case there's something there that the user still wants to manually save... but it can probably just be sent to the trash.

  • start Firefox v67.0
  • go to about:profiles
  • note the name of the current profile
  • quit Firefox
  • start Files
  • control+h to enable viewing of hidden files
  • go to ~/.cache/mozilla/firefox
  • rename the current profile folder to xxxx.default.HOLD
  • restart Firefox
4
  • 2
    You sir, are a gentleman and a scholar. Thank you.
    – user574440
    Jul 10, 2019 at 8:30
  • You saved my day. Thank you @heynnema
    – Cecil Paul
    Aug 19, 2019 at 5:14
  • Worked on Ubuntu 16.04, Firefox 68.0.2.
    – LRDPRDX
    Sep 4, 2019 at 15:36
  • 1
    worked on ubuntu 20.04, firefox 81.0
    – VeganEye
    Oct 4, 2020 at 1:56
8

I was having the same issue. Removing prefs.js did not fix the problem for me.

Restarting firefox via Menu -> Help -> "Restart with Add-ons Disabled" and choosing to restart in "safe mode" gave me a working browser.

I opened a regular instance of firefox again and it was still not working (obviously). I repeated the "Restart with Add-ons Disabled" but selected "Refresh Firefox" at the final step and it seems to have fixed the problem.

I went back through the preferences section and have changed back all of my settings there and I haven't broken the browser yet.

Again, this doesn't get to the root of the problem, but perhaps it narrows it down some? Maybe someone else knows more about what all gets reset when you choose "Refresh Firefox"?

2
  • This worked for me; however, in the meanwhile I reconstructed a new firefox profile which is fully functional (including add-ons) and I will stick to that! May 23, 2019 at 12:15
  • Worked correctly in Ubuntu 19.04 with newly upgraded Firefox 69. This new one has the weird symptom that no url causes browser to connect or open content, not even "about:config" or "about:profiles"
    – pauljohn32
    Sep 25, 2019 at 14:39
2

Had the same issue after updating Firefox to 67 on Ubuntu 18.04.

My issue could be solved by removing pref.js in my firefox-profile folder. This would be easier than manualy reconstructing everything after creating a new profile.

Steps to reproduce

  • Terminate Firefox
  • Go to your profile cd ~/.mozilla/firefox
  • Do a backup of your Mozilla profile first: cp -r ./firefox ./backup_firefox_backup
  • Navigate to your profile folder (the subdir with the random-string)
  • Remove prefs.js rm prefs.js
  • Restart Firefox

Haven't had time to resolve, which setting in prefs.js is at fault. If I find it, I may post an update.

1
  • Thanks for the suggestion, but this didn't work for me. May 23, 2019 at 12:14
2

Happened to me on apt-get upgrade to 67.0 on Ubuntu. No matter what I typed into the URL bar the page would just display the loading icon but not actually attempt any load. Even after killing the process and restarting Firefox manually.

My fix:

  • visit about:profiles
  • on the top-right corner of the page there is a button that says "Restart normally...", click this, the browser will restart itself, and magically it loads pages again
0

For now the best workaround until the Mozilla Dev team gets it going again is to downgrade to ESR Version.

1) Goto https://www.mozilla.org/en-US/firefox/all/

2) Select Extended Suppor trelease version

3) Live with v60 for some days / weeks

0

I had the same issue today and none of the answers worked. I then tried to start Firefox in safe mode and it suddenly worked.

You can go into safe mode by typing about:support in the address bar and click try SafeMode.

If that works for you, try isolating which addon causes this to happen. In my case, it was ublock origin! When I disabled it, Firefox worked again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.