14

I have been using Firefox on Ubuntu 18.04 for several weeks. I currently have firefox 67.0 (freshly updated). Since the update, firefox cannot connect to the internet anymore. The internet is working fine. I am writing this post from the Opera browser the I installed on Ubuntu 18.04 after the problems with Firefox.

I tried to follow the suggestions of this post. Explicitly I tried the following:

  1. Change proxy setting, in about:preferences Network Settings. I tried the options "no proxy", "Auto-detect proxy" and "Use system proxy" (the latter was the default).
  2. In about:config I set the "network.dns.disableIPv6" to TRUE
  3. In about:config I set the "network.dns.disablePrefetch" to TRUE

The issue seems firefox-specific. Opera does not give any problem. Pinging to www.google.it works fine (so no DNS problems).

I am fine using Opera, but I would also like to understand hwo to fix the issue in Firefox!

  • 3
    Have you tried starting Firefox with a new, blank profile? – Jos May 22 at 9:47
  • 2
    Thanks, @Jos, I followed your suggestion. With a blank profile I can regularly connect to the Internet. I will now try to move the important info to the new blank profile and see if the problem is solved while keeping all my needed info. – Fabio Marroni May 22 at 9:56
  • @Jos, if you set your comment as an answer I will be happy to accept it. Just as un update, copying important information from the old profile to the new one is slightly more than a 5 minutes job (support.mozilla.org/en-US/kb/…). Also, given the risk of importing the corrupting piece when copy the info, I will rather redo all the logins and preferences (not much really). I will also keep using both Opera and Firefox for a while! – Fabio Marroni May 22 at 10:10
  • Even though my suggestion helped you, I don't believe the question why Firefox didn't retrieve web pages has been fully answered. Sure, something in your profile must have messed things up, but we don't know what. So I won't post an answer just yet. – Jos May 22 at 10:18
  • 1
    @FabioMarroni I understand. You already fixed it... the hard way :-) It took some time for me to research the problem and document the easier fix. Anyway, the docs you refer to indicate "As the asker, you have a special privilege: you may accept the answer that you believe is the best solution to your problem", and for at least 9 other people it worked for them, as seen by their up votes. You can obviously decide for yourself :-) – heynnema May 28 at 14:14
18

The easy fix, with no profile or preferences rebuilding required...

This just renames the current Firefox cache folder. Firefox recreates this folder at next launch. The .HOLD only saves the old folder as a backup, just in case there's something there that the user still wants to manually save... but it can probably just be sent to the trash.

  • start Firefox v67.0
  • go to about:profiles
  • note the name of the current profile
  • quit Firefox
  • start Files
  • control+h to enable viewing of hidden files
  • go to ~/.cache/mozilla/firefox
  • rename the current profile folder to xxxx.default.HOLD
  • restart Firefox
  • You sir, are a gentleman and a scholar. Thank you. – Rudi Kershaw Jul 10 at 8:30
3

I was having the same issue. Removing prefs.js did not fix the problem for me.

Restarting firefox via Menu -> Help -> "Restart with Add-ons Disabled" and choosing to restart in "safe mode" gave me a working browser.

I opened a regular instance of firefox again and it was still not working (obviously). I repeated the "Restart with Add-ons Disabled" but selected "Refresh Firefox" at the final step and it seems to have fixed the problem.

I went back through the preferences section and have changed back all of my settings there and I haven't broken the browser yet.

Again, this doesn't get to the root of the problem, but perhaps it narrows it down some? Maybe someone else knows more about what all gets reset when you choose "Refresh Firefox"?

  • This worked for me; however, in the meanwhile I reconstructed a new firefox profile which is fully functional (including add-ons) and I will stick to that! – Fabio Marroni May 23 at 12:15
2

Had the same issue after updating Firefox to 67 on Ubuntu 18.04.

My issue could be solved by removing pref.js in my firefox-profile folder. This would be easier than manualy reconstructing everything after creating a new profile.

Steps to reproduce

  • Terminate Firefox
  • Go to your profile cd ~/.mozilla/firefox
  • Do a backup of your Mozilla profile first: cp -r ./firefox ./backup_firefox_backup
  • Navigate to your profile folder (the subdir with the random-string)
  • Remove prefs.js rm prefs.js
  • Restart Firefox

Haven't had time to resolve, which setting in prefs.js is at fault. If I find it, I may post an update.

  • Thanks for the suggestion, but this didn't work for me. – Fabio Marroni May 23 at 12:14
1

Happened to me on apt-get upgrade to 67.0 on Ubuntu. No matter what I typed into the URL bar the page would just display the loading icon but not actually attempt any load. Even after killing the process and restarting Firefox manually.

My fix:

  • visit about:profiles
  • on the top-right corner of the page there is a button that says "Restart normally...", click this, the browser will restart itself, and magically it loads pages again
0

For now the best workaround until the Mozilla Dev team gets it going again is to downgrade to ESR Version.

1) Goto https://www.mozilla.org/en-US/firefox/all/

2) Select Extended Suppor trelease version

3) Live with v60 for some days / weeks

0

Firefox is a Web browser that is smaller and faster but there might exists a problem like it can't connect to server even if internet is working so at first you need to make sure that the address is correct like www.example.com instead of ww.example.com and if your computer or network is protected by a firewall or proxy,make sure that Firefox Developer Edition is permitted to access the Web.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.