1

sorry i'm new here. here's (quite, sorry about that) a bit of background info for this post: basically I used to run zorin 12 core but it effed up somehow after I did a sudo apt-get update/upgrade and shut down the machine. I booted it up the next day, it didn't show the zorin dot grid background or user logos, it froze on first login attempt at the login screen, then I clicked cancel, then after the 2nd login attempt it temporarily flashed a bunch of code before it went to a black screen with a white file icon labelled documents. and then it boot looped back to the same login screen again

and because I couldn't fix that, I just gave up, nuked the zorin partition (I already have a backup of the documents that were stored on the zorin partition in a Win10 folder) and installed ubuntu 18.04 via a USB stick I randomly found that happened to have the ISO on it. Win10 was already on there as it was a dual boot for my (sort of, me mates helped me build it) self-built machine.


Anyway, after the minimal install and using it a few times, I got fed up of the purple screen at login and made my own wallpaper in GIMP to replace it with.

I followed the advice in this thread (Cannot change login screen background in 18.10) to attempt to change my login background screen and basically this happened - when I rebooted the system to see if the new wallpaper had been set, I got a grey screen, my cursor kept moving frantically all over the place (but in a weird kind of slo-mo where you could see loads of other cursors behind it) and I had to move it quickly to the password box to be able to login.

what perplexes me is that I've triple checked the code in the gdm3.css/ubuntu.css and it doesn't make sense as I've followed the advice (from the top answer) to the letter. is this a bug? have I stupidly done something wrong without realising? i'll add a screenshot of the code in question, for reference (i've highlighted it to point out what i've edited)

the screenshot can be found here

EDIT: the cursor problem has now disappeared, however, the screen is still grey and my custom background image still isn't showing.

ANOTHER EDIT: tried rebooting AGAIN, login screen is still grey, when I lock the screen and login again, the screensaver is the warty final ubuntu one and the login screen is still grey.

YET ANOTHER EDIT: as @PRATAP suggested, I tried changing the background colour to green and it just went back to the original problem.

AND ANOTHER THING (yes, mr steptoe?)... @PRATAP the terminal can't locate package flat-remix-gnome and when I do that other command it says there's only one other alternative which is the ubuntu.css

  • 2
    edit your code.. you missed ; background-size: cover; – PRATAP May 22 at 1:55
  • thanks i'll update it and see what happens – scousepunx May 22 at 1:56
  • just updated the code the cursor problem's gone but my screen's still grey. any ideas? – scousepunx May 22 at 2:03
  • Hi.. your screen is gray you mean login screen? what is the output of ls -l /etc/alternatives/gdm3.css and your OS is Ubuntu 18.04 rite? – PRATAP May 22 at 2:05
  • could it be permissions issue on the jpg? maybe sudo chmod 777 /usr/share/backgrounds/wildfire.jpg or similar??? – Joshua Besneatte May 22 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.