1

I use this command:

ssh "directory\myusername"@an.ip.address.here

Then I fill out this window that pops up:

enter image description here

And this is my log:

Welcome to the remmina log window
...
[SSH] TCP KeepAlive enabled
[SSH] TCP_KEEPIDLE set to 20
[SSH] TCP_KEEPCNT set to 3
[SSH] TCP_KEEPINTVL set to 10
[SSH] TCP_USER_TIMEOUT set to 60000
[SSH] ssh_packet_userauth_failure: Access denied for 'none'. Authentication that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
[SSH] ssh_packet_userauth_failure: Access denied for 'password'. Authentication that can continue: publickey,gssapi-keyex,gssapi-with-mic,password

As you can see Remmina just plain didn't pass along my username or password, left them apparently as 'none' and 'password.'

Alternatively, it is weird it says the method for password is denied, then immediately lists password as an acceptable authentication.

I can plain ssh with exactly the ssh at the top correctly. What setting am I missing that Remmina fails to do this with the same settings, connect string, and password?

1 Answer 1

0

Looks like the amazon desktop client does some non-standard remote desktop voodoo.

You can get this working if you use wine:

sudo apt-get install wine-stable
cd Downloads/
wine Amazon+WorkSpaces.msi
wine start Amazon+WorkSpaces.msi
cd .wine/drive_c/Program\ Files\ \(x86\)/Amazon\ Web\ Services\,\ Inc/Amazon\ WorkSpaces/
cd vchan_plugins/
ll
rm pcoip_vchan_remoteprintclient.dll
cd ..
wine workspaces.exe 

It is necessary to remove the .dll or else the client keeps crashing.

Anyway, this solution with emulation works, but is not satisfactory. I'd like to use a proper remote desktop client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.