0

In a recent past, I was using Unity, with Ubuntu 16.04. When I selected and opened a document in Nautilus, the display swap directy to the application corresponding to the document and this application was opening the requested document.

Now, with GNOME, under Ubuntu 18.04.2, when I select a document and ask for its opening, nothing happends. I need to swap manually the display the needed application, which was opened in the background, with Alt+tab. Worse, if a former document was openend by the same application, this first document is displayed, not the second one. I need then to swap manually furthermore to the second document with Alt+² Is there a way to improve this ? (Note that my opening preferences are double-click.) Thanks in advance.

  • 1
    @vanadium Did you see my up-date of May 22nd ? – Michel L May 25 '19 at 8:16
1

By default, and for many users, annoyingly, Gnome Shell indeed will not immediately focus a new window you open. Instead, it will display a notification "Your window is ready". You can then click that notification to go to the window, apart from hunting for the new window yourself. Aggravating the issue is that the behaviour does not appear to be consistent, at least not to me.

To immediately get the window you need, you can install a Gnome Shell extension, Noannoyance. The "out-of-the-box" supported way to install that extension is using Software Center. Search "noannoyance". Alternatively, install the package gnome-shell-extension-no-annoyance using the terminal (sudo apt install gnome-shell-extension-no-annoyance).

You may need to install GNOME Tweaks to turn the extension on. To install Tweaks, search "tweaks" in Software center, and locate and install "GNOME Tweaks". After launching Tweaks, you will find the extension on the "Extensions" tab, where you can enable it (if not already enabled during install) by changing the slider.

| improve this answer | |
  • Hello, Is there nobody to help me ? – Michel L Jun 12 '19 at 17:48
  • It works for me and seeing the extension website, for most other people. I guess you did not succeed to successfully install the extension. Otherwise, you would see it appear in Gnome Tweaks, shown as "Noannoyance". – vanadium Jun 15 '19 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.