0

I have installed Ubuntu at the second SSD drive in my laptop, but when the Grub shows up and I choose Ubuntu - the following error appears: "error: failure reading sector 0x728b6c0 from hd1. You need to load the Kernel first." The sector is different each time I try to boot in. Windows 8 boots in normally. Do you have any ideas how to fix this? Grub repair doesn't help...

  • Are both OSes installed in UEFI mode? – GabrielaGarcia May 20 at 22:34
  • Windows 8 is for sure UEFI mode. Following the instructions, I tried to install Ubuntu in UEFI mode as well. How do I check if it's true? Is that even possible without the access to Ubuntu? – lvndsky May 20 at 22:37
  • Easiest way to know: Are you booting Windows 8 from the Grub menu? If so Ubuntu is also in the same mode. Otherwise it's in Legacy. – GabrielaGarcia May 20 at 22:40
  • Yes, I do. Grub let's me choose either Windows (which boots just fine) and Ubuntu (that throws some errors) – lvndsky May 20 at 22:42
  • OK, that's good and allows some assumptions. 1. Grub was installed in the already existing EFI partition that's in the first SSD. 2. The second SSD where Ubuntu main partition was created may be defective. – GabrielaGarcia May 20 at 22:45
0

I suggest that you do three things...

- Use the Disks app to check the SMART Data & Tests

  • Edit your question with a screenshot of the SMART Data and I'll take a look

  • run the SMART Tests

- fsck your Ubuntu partition

  • boot to a Ubuntu Live DVD/USB
  • open a terminal window
  • type sudo fdisk -l
  • identify the /dev/XXXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/sdb3 # replacing XXXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

- Perform a bad block scan

Boot to a Ubuntu Live DVD/USB, backup any data from /dev/sdb3, and in the terminal...

Note: do NOT abort a bad block scan!
Note: do NOT bad block a SSD
Note: backup your important files FIRST!

sudo e2fsck -fcky /dev/sdb3 # read-only test

or

sudo e2fsck -fccky /dev/sdb3 # non-destructive read/write test (recommended)

The -k is important, because it saves the previous bad block table, and adds any new bad blocks to that table. Without -k, you loose all of the prior bad block information.

The -fccky parameter...

   -f     Force checking even if the file system seems clean.

   -c     This option causes e2fsck to use badblocks(8) program  to  do  a
          read-only  scan  of  the device in order to find any bad blocks.
          If any bad blocks are found, they are added  to  the  bad  block
          inode  to  prevent them from being allocated to a file or direc‐
          tory.  If this option is specified twice,  then  the  bad  block
          scan will be done using a non-destructive read-write test.

   -k     When combined with the -c option, any existing bad blocks in the
          bad blocks list are preserved, and any new bad blocks  found  by
          running  badblocks(8)  will  be added to the existing bad blocks
          list.

   -y     Assume  an answer of `yes' to all questions; allows e2fsck to be
          used non-interactively.  This option may not be specified at the
          same time as the -n or -p options.

Update #1:

After checking the BIOS version with sudo dmidecode -s bios-version it was determined that there was a newer BIOS available. Installed the newer version and so far it seems to have fixed the problem.

  • Thank you for your answer. Maybe you could find something out in this output (sorry, I don't have enough reputation to post images in the post): imgur.com/a/P373aEO – lvndsky May 21 at 10:25
  • @lvndskyThanks for that output, however it didn't give me any new information. I would like to see the SMART Data window though. You can follow my answer. Report back. – heynnema May 21 at 12:28
  • Here's the output from the test : imgur.com/a/YNoFhxD Is that what you expected me to show? Thank you so much for your involvement :) – lvndsky May 21 at 19:19
  • I was also hoping to see the Disks SMART Data window. In your current image, you didn't do the command correctly. I'll bet it only took a few minutes, yes? Use the correct, complete, recommended command that I show, and it should take many hours. Report back. – heynnema May 21 at 19:27
  • Is sdb a HDD or SSD? Don't bad block it if it's an SSD. – heynnema May 21 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.