I installed 11.10 Big mistake, can't find anything! Chrome, I installed it, removed it because I couldn't find it re-installed it, still can not find it. Considering going back to 10.04

  • Open up dash home and try typibg chrome into the search box . Dont go back, this sounds more of a user training issue – rlemon Mar 20 '12 at 10:59
  • what do you mean by couldnot find it ? Did you not know how to use unity if you are using unity? Just press super key and type chrome – sagarchalise Mar 20 '12 at 11:18
  • I have same problem with a fresh install of Ubuntu 12.04. I installed the Chrome DEB from Google web site. It appears to install normally (Software Centre gets launched), but Chrome is no where to be found. Actually the 'dash home' doesn't seem to find anything no matter which tab and search terms I use. The only hint of Chrome is in system settings, details, where I can make Chrome the default for the Web - but that still doesn't give me any way to actually launch Chrome. – Tom May 14 '12 at 7:11
  • 11.10 is end of life it has no repository’s for software and will never receive any updates or support here, use 12.04lts, 14.04lts or the latest development version (15.10 as of writing) – Mark Kirby Dec 16 '15 at 9:54

Chrome, or chromium (which is chrome with all the required plugins as flashplayer etc..) must be installed from software center. When you are sure that the installation is complete and successful, you must go to the launcher in unity, and search for "chrom". Chrome, or chromium should appear in the list. Then, open it, and create a shortcut in the launcher so u can enter it easily afterwards :D

(chrome must be downloaded manually here: https://www.google.com/chrome?platform=linux)

  • Instead of creating a short cut, after launching Chrome and with the browser running, you'll find its icon in the Launcher. Right-click on it and choose "Keep in Launcher". – user25656 May 15 '12 at 2:12

type google-chrome-stable in terminal. I installed it the same way via chrome website and in the installation note I noticed it said this program is run from terminal

  • yes! ---------- – Justin Aug 11 '16 at 17:25

Maybe you need to reboot?

Let me explain.... I had a similar problem with a fresh install of Ubuntu 12.04. I installed the Chrome DEB from Google web site. It appeared to install normally, but Chrome was no where to be found.

You should be able to find Chrome in the dash search (available by clicking on the dash home button), but somehow it was not properly initialized yet so it wasn't working properly. It is possible that this was my first session with this installation (I can't remember).

Any, restarting the system fixed the dash search, allowing me to find and use Chrome.


The Better way to do it is-

  1. Download the .deb file from the chrome site..

  2. Install Gdebi package installer..

  3. Right click on the .deb file and select "open with gdebi package installer"

  4. Click on Install..

5.you'll find it installed...!! :)

hope it works for you..!! It always did for me...!! All .deb files should be installed through GDebi in 11.10... :)

  • Please explain why it is better? Just because it worked for you doesn't automatically make it better for others. – user25656 May 15 '12 at 2:08
  • I have not calles it better because it woked for me. When I was using 11.10 I was facing simiar issues with many packages and in a few forums(unfortunately i cant provide their links now) i found out that this was a problem faced by many in 11.10. May be a bug. And in all the forums using this method was mentioned to work. In Ubuntu 11.10 the .deb files when opened with "Software Center" give the error "NOT FOUND"..!! And Chrome is not in the default software repository of 11.10. Chromium is. And like .deb files, softwares enabled through external PPAs give trouble too. Hope it answers you :) – Nirmik May 15 '12 at 3:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.