0

Laptop - Lenovo thinkpad P52 uname -a

Linux ivan-ThinkPad-P52 5.1.3-050103-generic #201905161442 SMP Thu May 16 18:44:30 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

sudo lshw -c video

 *-display                 
   description: VGA compatible controller
   product: GP107GLM [Quadro P1000 Mobile]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:160 memory:a3000000-a3ffffff memory:60000000-6fffffff memory:70000000-71ffffff ioport:2000(size=128) memory:a4080000-a40fffff


*-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:600-5ff iomemory:400-3ff irq:158 memory:604a000000-604affffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff

/etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows2009'"
GRUB_CMDLINE_LINUX=""

sudo ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001CBBsv000017AAsd0000225Fbc03sc00i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-410 - third-party free
driver   : nvidia-driver-418 - third-party free
driver   : nvidia-driver-396 - third-party free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-430 - third-party free recommended
driver   : nvidia-driver-415 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin

I tried installing drivers (multiple versions) using this tutorial https://www.mvps.net/docs/install-nvidia-drivers-ubuntu-18-04-lts-bionic-beaver-linux/

I also tried using ubuntu-drivers autoinstall and removing any drivers before using sudo apt purge nvidia* (I ensured none drivers were there when typed dpkg -l | grep nvidia)

If I have Hybrid graphics enabled in BIOS, I can see valid nvidia-smi output, however laptor uses integrated graphics card Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)

If I set Discrete graphics card, the nvidia-smi returns

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

and also in nvidia-settings I see only blank page. How should I please set up nvidia driver?

0

it was answered by https://askubuntu.com/users/757577/moosee333 in the comment

The manual installation of nvidia drivers worked for me. I hope it helps you! See: Installing NVIDIA drivers for Ubuntu 18.04 – moosee333 May 22 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.