0

I interrupted my upgrading from 16.04 to 18.04 by accident when doing

sudo apt dist-upgrade

and now I cannot use apt anymore. When I do

sudo apt install -f

it shows:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libavcodec57 : Depends: libc6 (>= 2.27) but 2.23-0ubuntu11 is installed
 libcdio17 : Depends: libc6 (>= 2.27) but 2.23-0ubuntu11 is installed
 libgstreamer-gl1.0-0 : Depends: libegl1 but it is not installed
                        Recommends: gstreamer1.0-gl but it is not installed
 libjack-jackd2-0 : Depends: libc6 (>= 2.27) but 2.23-0ubuntu11 is installed
 libjack-jackd2-0:i386 : Depends: libc6:i386 (>= 2.27) but 2.23-0ubuntu11 is installed
 libkf5declarative5 : Depends: libkf5declarative-data (= 5.18.0-0ubuntu1) but 5.44.0-0ubuntu3 is installed
 libkf5service-bin : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libkf5service5 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5dbus5 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
               Depends: qtbase-abi-5-9-5
 libqt5quick5 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
                Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
                Depends: libqt5qml5 (>= 5.9.5) but 5.5.1-2ubuntu6 is installed
                Depends: qtbase-abi-5-9-5
                Depends: qtdeclarative-abi-5-9-5
 libqt5waylandclient5 : Depends: libqt5core5a (>= 5.9.5+dfsg~) but 5.5.1+dfsg-16ubuntu7.5 is installed
                        Depends: libqt5gui5 (>= 5.9.5+dfsg~) but 5.5.1+dfsg-16ubuntu7.5 is installed
                        Depends: qtbase-abi-5-9-5
 libqt5waylandcompositor5 : Depends: libqt5core5a (>= 5.9.5+dfsg~) but 5.5.1+dfsg-16ubuntu7.5 is installed
                            Depends: libqt5gui5 (>= 5.9.5+dfsg~) but 5.5.1+dfsg-16ubuntu7.5 is installed
                            Depends: qtbase-abi-5-9-5
                            Depends: qtdeclarative-abi-5-9-5
 libqt5xml5 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
              Depends: qtbase-abi-5-9-5
 libwayland-egl1-mesa : Depends: libegl1 but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I have tried to use synaptic to fix broken package, but I still see this

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

error. And

dpkg --get-selections | grep hold

does not show anything. Can anyone help me?

  • Well, it might be easiest to try finishing your dist-upgrade. Try running it again. Synaptic is not the same as a dist-upgrade, and won't be able to fix the terrifying mix of packages from different releases. – user535733 May 20 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.