23

Summary of Issue
Last Friday, I installed updates to Ubuntu 18.04 with sudo apt-get update && sudo apt-get upgrade. Some of these updates required a restart. Upon restart, after GRUB, boot got stuck on a purple screen before the Ubuntu logo/login. I can't access the terminal at this step through Ctrl + Alt + F7/T/F1/F2 methods. Recovery mode does not work, and gets stuck at Loading initial ramdisk...

Attempts to Resolve
As stated above, recovery mode did not work.

  1. Attempted to use Boot Repair, this ran successfully but did not resolve the problem. Output from this attempt here.

  2. Next, I backed up some files then attempted a fresh install of 18.04.2. This worked, but as soon as I grabbed the ~400 MB of updates for this clean install, I encountered the same problem as before. I tried using both the Software Updater, and terminal. I've got no idea what update is breaking, here's a full log of updates run.

  3. Saw what may be a related issue here: Ubuntu freeze on boot purple screen. Seeing that this user seemed to have an issue with kernel updates, I excluded kernel updates from running and tried again, still the same result as before.

So at this point, I'm at a loss as to how to proceed. I'm hoping I can get some help on this thread. Otherwise, I may need to downgrade to 16.04 or upgrade to 19.04...

EDIT 1
Looks like this bug's already been reported to Canonical. Appears that it could be related to recent Intel microcode updates or an acpi issue.

EDIT 2 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620 <- Intel microcode updates on ASUS causing kernel to get stuck has been identified as the crux of the issue. Confirmed temporary workaround to get machines bootable is in the accepted answer below.

A video from youtube regarding this problem and the documented workaround: https://www.youtube.com/watch?v=NbxrSaclKRc

EDIT 3 As of 09/03/2019, I've installed the most recent BIOS update from ASUS (from within Windows 10) and can confirm that this enables me to boot normally into Ubuntu without the need for the dis_ucode_ldr option in GRUB. I would recommend this as a more sustainable, definitive fix for the problem than using the workaround at this point.

  • Do you get a pure purple screen, or do you see the Ubuntu logo with 1-5 dots underneath the logo? What version did you upgrade from? How old is your computer? Intel video, or something else? – heynnema May 20 '19 at 16:51
  • Just a purple screen, no Ubuntu logo with the dots. I was already on 18.04, just running regular software updates, not going from a major version to another one. Running an Asus VivoBook X530FA_S530FA which is barely a couple months old. Intel integrated video. – leizmonk May 20 '19 at 17:38
  • Two things. Can you boot to Recovery Mode? Try this... at the GRUB menu, select the desired default boot, hit the "e" key to enter edit mode, use the arrow keys to find "quiet splash" and change it to "quiet splash nomodeset", then control-x or F10 to continue to boot. See if that boots. Screen resolution will be off, but that's ok. – heynnema May 20 '19 at 17:44
  • Booting to recovery mode doesn't work, as mentioned above I hit the "loading initial ramdisk..." step and then it just hangs. I'll try this sugguestion with nomodeset and see if it does anything. – leizmonk May 20 '19 at 17:54
  • quiet splash nomodeset didn't work. Still getting to a purple screenn and hanging – leizmonk May 20 '19 at 19:30
14

well I also have a Asus ZenBook UX433FA doing this issue, I was running 18.10 and did apt-get upgrade last night and broke the system. I've since used this method livecd recovery to upgrade to 19.04 still no luck with booting. have multiple kernels installed none of which will get past the "loading initial ramdisk". while using the above i installed kernel v5.1 with ukuu no luck either and threw errors about dkms for nvidia driver incompatible with kernel version.

Edit DMESG log managed to get the dmesg from a partial boot here

boot-repair log info here occasionally it will boot with errors unsure of what info or how to gather info on these occasions though to help with debug.

just a side note windows hadn't been loaded for about a month prior to this. I know this should probably be a comment but I don't have enough credit.


Edit 2

For anyone having a similar problem, try booting with microcode updates off: add dis_ucode_ldr to the kernel command line (from GRUB if you cannot boot)

can confirm this allows for boot.

| improve this answer | |
  • 1
    One common thread I'm noticing here is that those experiencing this issue including myself all have Asus laptops of some kind or another, including 3 with the Zenbook UX433FA (one on this separate thread askubuntu.com/questions/1143309/…). Any way for us to escalate this to Canonical or Asus? – leizmonk May 21 '19 at 14:22
  • Also, just to confirm, you attempted to upgrade to 19.04 and that was also not bootable? Looks like I'm going to have to downgrade to 16.04 if this problem persists w/o long-term resolution. – leizmonk May 21 '19 at 14:24
  • 2
    I confirm that my UX433FN can boot by adding dis_ucode_ldr (at the end of brub command line starting with linux) – 56ka May 22 '19 at 13:12
  • 3
    This is the confirmed workaround for now as per: bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620. Will still have to wait for a long-term fix though. – leizmonk May 22 '19 at 14:36
  • 4
    From the grub menu highlight the os/kernel to boot and press "e".. then from that screen arrow down to the line starting with Linux and add dis_ucode_ldr to the end of this line. Then follow the command at the bottom to boot. – sealy Jun 20 '19 at 20:38
7

I had the same issue on a brand new Asus Vivobook s15 S530FA (intel i5-8265U). After installing the first updates in ubuntu 18.04.2 LTS the boot screen got stuck in "loading initial ramdisk".

As mentioned in the above comments a workaround to this is disabling the microcode in the grub options adding: dis_ucode_ldr. This solution works for debugging this issue but it's not recommended for regular use.

The best solution so far I think is to downgrade the intel-microcode package to the previous version:

sudo apt-get install intel-microcode=3.20180312.0~ubuntu18.04.1

Then freeze the package to avoid accidental upgrade:

sudo su 
echo "intel-microcode" hold | dpkg --set-selections

For now I'll avoid installing intel-microcode=3.20190514.0ubuntu0.18.04.3

| improve this answer | |
  • I agree this' way to go, but the problem I have is, in terminal mode, I lost access to internet. Do you know how to reconnect? – horaceT Jun 20 '19 at 21:16
  • 1
    @horaceT I guess you could try to connect in terminal using "dhclient" or iwconfig $iface essid $essid_name key $password I recommend that you first try disabling the microcode at boot adding: dis_ucode_ldr Then you can boot normally and replace the intel-microcode package, then hold it. – Juan Zurano Jun 27 '19 at 17:48
  • Thanx! This solved problem for my Vivabook S14 – Ivan Vulović Jul 16 '19 at 8:45
4

I found a durable solution in the bug tracker (see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620 WORKAROUND 3: upgrade BIOS)

ASUS released a BIOS update for the UX433FN the 2019.06.17 (please check your exact model)

WARNING: Updating BIOS is a risked operation and can not be reverted !!

Overview: You basically have to download a zip, extract the file it a USB key, go into BIOS and start Flash Utility, select the file and that's it (you can do it from Ubuntu).

Here are the detailed steps:

  1. Go to asus drivers download page (for me https://www.asus.com/us/Laptops/ASUS-ZenBook-14-UX433FN/HelpDesk_BIOS)
  2. Download BIOS file (UX433FNAS306.zip)
  3. Extract the file from zip archive to your USB key -> UX433FNAS.306 (my advice: remove the zip file for ensure you will not confund the files after)
  4. Reboot and go to setup (BIOS), navigate to Advanced > Start Easy Flash
  5. In the scary blue program navigate to select the file UX433FNAS.306 (NOT the zip !!!)
  6. Press enter and confirm (it could freeze for 1 minute but it works)
  7. (If you edited your grub now you can set it back to normal)

The scary menu (image pretext)

ASUS update page

| improve this answer | |
2

Having exactly the same issue on a brand new Asus ZenBook UX433FA. Installed Ubuntu 18.04.02 with dual boot, started up without problem, but after installing the first batch of upgrades and rebooting I got the same purple screen.

I found a temporary fix by disabling Secure Boot (booting with nomodeset, then command line sudo mokutil --disable-validation). Works fine after that, so I suspect it has something to do with with some driver(s) included among the updates. Any suggestion how to fix this more permanently?

| improve this answer | |
  • 1
    Can unfortunately not comment above, but I guess this is at least a partial answer. – Martin May 20 '19 at 21:10
  • Can you detail how you did this temporary fix? I'd like to try it/have it in case this happens again. I'm unclear how to access the command line when the boot itself is totally FUBAR. – leizmonk May 20 '19 at 21:24
  • Also, if you can, would you share your boot log here for folks to maybe help debug? – leizmonk May 20 '19 at 21:49
2

I have exactly same problem with a Dell Precision Tower 5810. I allowed an ubuntu update to occur this morning (Jun 19, 2019). After reboot, I come to GRUB screen, hit return, face a blank purple screen, then nothing happens.

Hard power down, and reboot. Go to Advanced Options for Ubuntu, recovery mode for kernel 4.15.0-52-generic, it couldn't even display the options correctly. Can't get to terminal mode no matter what i do (ctrl alt F4, F5...). Strange thing is, at this state, the behavior of the system seems random. I tried this recovery mode quite a few times, and the behavior is different every time.

| improve this answer | |
1

There is a temporary fix now posted on: bugs.lauchpad run this command in the terminal:

sudo apt install intel-microcode=3.20180312.0~ubuntu18.04.1

then when launching linux do so with quiet splash only I did it and it worked for me on my Asus UX433FA. If you cannot access the terminal when booting press e and try to make ro nomodeset quiet splash or any combination of nomodeset quiet splash without the ro in front anything that can get you to black terminal screen or logged in. If you reach the black terminal screen try ctr alt f5 or f4 and so on to access the linux terminal and run the command

| improve this answer | |
  • I tried this, but at the command line, i don't have connection to internet. Any suggestion? – horaceT Jun 20 '19 at 1:59
  • An easier solution is to write dis_ucode_ldr in the grub boot option, you do not need internet for this. Let me know if you need more info on that! – ezprob Jul 2 '19 at 18:57
1

I want to post what the final resolution turns out to be to my problem above.

I contacted Dell's support team, and they said the culprit is Nvidia driver update. They also said there's no known way to unroll the change. So, I have to reinstall the entire ubuntu 18.04 from scratch, wiping out everything on disk.

Similar problem happened to me two yrs ago. After an innocuous ubuntu update, I couldn't log back in. Struggling for a week, tried every trick I could find on SO, I ended up reinstall.

Lesson learned : Nvidia driver update is failure-prone. Be very careful accepting a driver update.

| improve this answer | |
  • 1
    Once bitten twice shy. I think I will avoid NVIDIA even in a dual boot machine. Too much grief with linux. – Robin May 5 at 16:24
  • 1
    @Robin It's a shame Nvidia still having driver update issues. I still don't accept the ubuntu push updates. I might miss something, but I just don't care. – horaceT May 9 at 22:36
1

Here is a complete video about this problem: https://www.youtube.com/watch?v=NbxrSaclKRc

As said in the later edits, there is a firmware update that solves the problem.

Summary of the fix:

add the boot parameter: dis_ucode_ldr to /etc/default/grub

then update-grub

| improve this answer | |
0

I had the same symptom but just now realized if I do a cold-boot the system boots ok!
This was after software update today. But even after the S/W update,
1. if I do 'shutdown -r now' , I get the purple screen.
2. if I press shift key and enter grub2, and select one and press ctrl-X, the boot doesn't start, just stays in the purple screen.
3. I tried chaning some boot paramters in vain (like dis_ucode_ldr)

and I tried cold booting (shutdown the machine, and turn it on after a couple of seconds), it boots successfully. Hope anybody find this useful.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.