4

I tried installing Festival from Synaptic to use it with Orca, but it did not show up on Orca's speech synthesizer list.

I installed the following packages:

  • festival
  • festival-freebsoft-utils
  • speech-dispatcher-festival
  • festlex-oald
  • festlex-cmu
  • festvox-kallpc16k
  • festvox-kdlpc16k
  • festlex-poslex
  • festvox-don
  • festvox-ellpc11k

3 Answers 3

3

To all appearances, you should have the applications needed for festival to work with orca. Have you gone into Orca Preferences, Speech tab and changed the "Speech System" to 'GNOME Speech Services'? After that, you can change the "Speech synthesizer" to Festival.

2
  • The only option on the speech system list is "Speech Dispatcher"
    – spayk
    Nov 6, 2010 at 3:50
  • 1
    Did you install libgnome-speech7 when installing festival? Nov 7, 2010 at 21:32
0

I also ran into this problem but fixed it. For context, I'm on a Raspberry Pi 3 Model B.

Solution

Warning: un-commenting the line as I propose will make your orca dependent on festival_server running. You have been warned.

In /etc/speech-dispatcher/speechd.conf I un-commented (removed the hashtag at the beginning of the line)

AddModule "festival" "sd_festival" "festival.conf"

Then in one terminal I ran

festival_server

and finally in a separate terminal I ran

orca

Next Steps for The Reader

You'd probably want to start festival_server at startup by messing with your ~/.xsession because with that AddModule line un-commented orca will not start without festival_server running.

How I Came Up With Those Steps

Same as you I have

  • festival
  • speech-dispatcher-festival
  • festival-freebsoft-utils

I installed the latter two specifically because of this post. Unsure if they helped.

To discover what was going wrong I first tried man speech-dispatcher and that directed me to info speech-dispatcher and from there I learned about the config file. In /etc/speech-dispatcher/speechd.conf I un-commented the line

AddModule "festival" "sd_festival" "festival.conf"

Next I tried both orca and spd-say hello and ran into an error.

After further reading in /etc/speech-dispatcher/modules/festival.conf I saw that you have to run festival_server in order for spd-say or orca to work. That finally made things work and I was able to select from my installed festival voices in the orca settings menu, and orca spoke with festival when I applied those changes.

-2

try my script ;)

#!/bin/bash

#       Copyright Paolo Rotolo <paolorotolo@ubuntu-it.org>
#       
#       This program is free software; you can redistribute it and/or modify
#       it under the terms of the GNU General Public License as published by
#       the Free Software Foundation; either version 2 of the License, or
#       (at your option) any later version.
#       
#       This program is distributed in the hope that it will be useful,
#       but WITHOUT ANY WARRANTY; without even the implied warranty of
#       MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#       GNU General Public License for more details.
#       


sudo apt-get install festival
sudo apt-get install festvox-italp16k
sudo apt-get install festvox-itapc16k

echo "(set! main-path "/usr/share/festival")
(set! load-path (cons main-path load-path))(set! load-path (cons main-path load-path))" >> .festivalvarsr

echo "(set! main-path "/usr/share/festival")(set! libdir main-path)(set! lexdir (path-append libdir "dicts"))(set! voice_default 'voice_lp_diphone)" >> .festivalrc

sudo apt-get install gnome-speech-swift

espeak -v it -s 150 "Complimenti. Avete installato Festival sul vostro pc. La voce che sentite non è di festival. Per attivarlo andate nelle preferenze di orca e alla voce, sistema di sintesi vocale, selezionate Servizi sintesi vocale di GNOME. Alla voce, Sintetizzatore di sintesi vocale, selezionate Festival GNOME Speech Driver. Alla voce impostazioni della voce, selezionate Predefinita. Infìne, alla voce, persona, selezionate pc_diphone, se volete la voce maschile, oppure lp_diphone, se volete la voce femminile.
Orca verrà avviato automaticamente."

orca

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.