0

I recently tried dual booting Ubuntu on my laptop. I followed this guide and was able to successfully install and login to ubuntu. However now when I try to login, I get stuck at a purple screen with no login option. I tried looking around online and it seems like the problem lies with the nvidia graphics card.

I then found this guide and followed it. It worked at first. After adding "nomodeset" I was able to login. The desktop icons were all triple in size and everything looked zoomed in but i was in. From there I updated the drivers through "software and updates" and restarted. Nothing changed. I still get stuck at the purple screen and this time adding nomodeset results in a

P[some letter and numbers (don't remember exactly)] signature not signed with trusted key

I have secure boot off and fast startup off if that makes any difference.

I then found some other forum post that said to enter recovery mode. I tried that but even recovery mode froze after like two lines of text (or at least I think it froze. I waited ~5mins and other than the two initial lines of text nothing changed. It didn't give me any options or register keyboard presses).

Any ideas? I did "minimal install" for ubuntu i believe if that makes any difference.

  • I get this about 20 times over 2 second period during boot but it doesn't seem to effect the machine: PKCS#7 signature not signed with a trusted key. – WinEunuuchs2Unix May 20 at 19:59
  • Is there a way to login in through that? Because in mine it just stays in that terminal like screen with no login popup. – Akash May 20 at 20:25
  • Disable Secure boot in UEFI as it prevents loading the Nvidia drivers. – GabrielaGarcia May 26 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.