0

I am trying to install the desktop environment of lubuntu on Ubuntu 18.04.02 but I am getting the following error:

$ sudo apt install -y lubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lubuntu-desktop : Depends: lubuntu-gtk-core but it is not going to be installed
                   Depends: lubuntu-gtk-desktop but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any idea how to address this?

marked as duplicate by N0rbert, Eric Carvalho, karel, Kulfy, Fabby May 24 at 10:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • what happens if you run : sudo apt -f install && sudo apt update && sudo apt -f install && sudo apt update && sudo dpkg --configure -a && sudo apt autoclean -y && sudo apt autoremove ? – tatsu May 20 at 15:16