2

Specs

  • Asus Zenbook 14 UX433FN (NVMe PCIe SSD)
  • Ubuntu 18.10 and Windows 10 dual boot, Windows 10 working fine.

Background

Today my Ubuntu 18.10 suddenly gave me a "purple screen of death" after I closed my laptop lid (ie. it couldn't wake up from suspend).

After which, I forced shutdown and tried to reboot (both normally and with recovery mode), and both times it got stuck at Loading initial ramdisk...

Quirky Behaviour

After this I successfully reinstalled Ubuntu 18.10 using CD. TWICE.

Each time, after successfully installing graphics drivers and everything, Ubuntu automatically prompts me to do security updates etc. Before installing updates, I can use and boot into Ubuntu normally.

BUT after installing these updates successfully, and rebooting, I get stuck at Loading initial ramdisk... again.

Update! After my third re-installation, I decided to do sudo apt upgrade from command line directly instead of the GUI as I did previously.

I got the same error again!

This hints at the possibility of a bug or broken package in the apt repository. As this is a fresh Ubuntu 18.10 install, this is extremely puzzling.

Resolution attempts

  1. Use LiveCD as per https://help.ubuntu.com/community/LiveCdRecovery#Update_Failure.
  2. Update kernels before installing.
  3. Replacing quiet splash with nomodeset.

Why is this so? Is there a bug in the update repositories somewhere?

I can use Ubuntu without updating of course, but this leaves my computer vulnerable to security issues. In the long-run, being afraid of updating the computer lest I get this same error is quite stupid.

UPDATE:

A bug report has been filed. Apparently I'm not the only one affected.

https://bugs.launchpad.net/ubuntu/+bug/1829735

Apparently acpi_osi=off might work.

Potential Fix:

Apparently, this might be due to a known bug in Asus.

Check out bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620

Several solutions might be found there.

  • @whoever posted yesterday but deleted their answer, why did u do so? You did mention helpful advise that while it might not have answered my question directly, was still good troubleshooting advice? – Samleo May 22 '19 at 0:49
  • You can check my answer to askubuntu.com/a/1176658/456213. I fixed this problem on my Asus Zenbook 14 UX433FN. – ARG Sep 25 '19 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.