0

I can't install CMake on Ubuntu 18.10 because I get an error:

Ign.:1 http://pl.archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-libc-dev amd64 4.18.0-17.18
Błąd:1 http://security.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-libc-dev amd64 4.18.0-17.18
  404  Not Found [IP: 153.19.251.225 80]
E: Nie udało się pobrać http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_4.18.0-17.18_amd64.deb  404  Not Found [IP: 153.19.251.225 80]

When I try to use upgrade, I get next error:

> E: Nie udało się otworzyć pliku blokady /var/lib/apt/lists/lock - open (13: Brak dostępu)
E: Nie udało się zablokować katalogu /var/lib/apt/lists/
W: Problem przy odlinkowywaniu pliku /var/cache/apt/pkgcache.bin - RemoveCaches (13: Brak dostępu)
W: Problem przy odlinkowywaniu pliku /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Brak dostępu)
  • Welcome to Ask Ubuntu! Have you tried apt update first? Can you access the IP address using ping or a web browser? – Melebius May 20 at 9:06
  • You should also prepend LC_ALL=C to your commands to get the output in English, so everyone here can understand your error messages, e.g. LC_ALL=C sudo apt update. You should also post the exact commands you issued along with their output. – Melebius May 20 at 9:15
1

Have you tried to do an autoremove, update and then try to install cmake?

sudo apt-get autoremove
sudo apt-get update
sudo apt-get -y install cmake

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.