0

I am deploying the MAAS and JUJU as well as OpenStack. At present, I have installed MAAS(2.5), added all nodes and commissioned them by following the guide. However, when I install the JUJU via conjure-up, everything went great until juju bootstrap. Actually, the conjure-up can set the status of juju controller to deploying 18.04...

In MAAS dashboard as well as starting deploy the OS to JUJU controller node. After deployment finishing, the JUJU still tills me "Awaiting.." and are running machine configuration scripts.

log output:

Creating Juju controller "conjure-up-cloud-maas-ff8-357" on cloud-maas-ff8
Looking for packaged Juju agent version 2.5.0 for amd64
Launching controller instance(s) on cloud-maas-ff8...
- cxh7md (arch=amd64 mem=8G cores=4)  
Installing Juju agent on bootstrap instance
Fetching Juju GUI 2.14.0
Waiting for address
Attempting to connect to 192.168.2.1:22
Connected to 192.168.2.1
Running machine configuration script...
0

Sorry to hear that you're having difficulty, Kevin. The error message from Juju isn't very helpful:

Running machine configuration script...

This means that the machine is installing its software via cloud-init. At this stage, there is no output for Juju to interpret.

To learn more about how to fix the situation, you need to access the machine directly. That means using SSH to log in to the machine and monitoring the cloud-init output yourself.

ssh cloud-maas-ff8 # you may need to 
cd /var/log
less cloud-init-output.log

That will present you with a large log file that starts something like this:

Cloud-init v. 18.4-0ubuntu1~18.04.1 running 'init-local' at Sun, 19 May 2019 08:11:30 +0000. Up 1.00 seconds.
Cloud-init v. 18.4-0ubuntu1~18.04.1 running 'init' at Sun, 19 May 2019 08:11:33 +0000. Up 4.00 seconds.
...

If your work policies permit it, you should paste your output to paste.ubuntu.com for further help.

  • Thanks, Tim. Have fixed it. It is because of a network fault. In particular, the juju controller can't access the public internet. After I reconfiguring the network, everything worked fine. Thanks for your response. – Kevin Lee May 26 at 9:43
  • Really glad to hear that you're up and running. If you encounter any problems, the best place to ask for help is actually discourse.jujucharms.com – Tim McNamara May 27 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.