1

after login into my main account, I get a black screen that lasts up to an hour after which the desktop will usually load and works like normal.

zany130@andres-X470-AORUS-ULTRA-GAMING
    OS: Ubuntu 18.04 bionic
    Kernel: x86_64 Linux 5.0.17-050017-generic
    Uptime: 12m
    Packages: 4523
    Shell: bash 4.4.19
    Resolution: 2560x1080
    DE: GNOME 
    WM: GNOME Shell
    WM Theme: Arc-Dark
    GTK Theme: Arc-Dark [GTK2/3]
    Icon Theme: Paper
    Font: Roboto 11
    CPU: AMD Ryzen 7 2700X Eight-Core @ 
    16x 3.7GHz [53.5°C]
    GPU: GeForce GTX 1080
    RAM: 8407MiB / 16048MiB    

Update 1: Hello it's been a while so I'll give an update. My Ubuntu install is still crashing. For a time it got worse where 90% of the time my main account won't load. I created a second test account and that loads perfectly fine with no delay whereas the main could take hours(seriously I would go play ps4 while I waited)gotten better by removing some extensions as now its 50/50 whether I can sign in. Also a few things of note, my HDD indicator keeps blinking throughout the whole process. I have checked the disk for errors and it came back fine. I will try it again, though as maybe all the forced reboot did something. Sometimes it crashes before logging into an account but this is rare.so maybe on top of my having something messed up there's something also messing up the login globally. I haven't been able to pinpoint exactly what extensions, if it is an extension, crashes my account I have gone one by one enabling the extensions and deleting the seemingly responsible extensions and it will work for a few reboots and then start again IDK why but it seems like the act of disabling or enabling a extensions fixes the problem for the next boot. Sorry, this turned into such a long thing with so many ]posts I just wanted to document all I have tried to do and noticed. I'm at a loss as to what to do other than just using another account or disabling all the extensions before logging out or rebooting and then enabling them after I login. Idk if the last one would work

Update2: After trying Prateek kkY it worked for all of yesterday I tried several reboot and shutdowns and it was fine so I turned it off and today I went to use it and it wouldn't log in to my account again

Update3: I'm attaching my logs form a boot that took an hour on the black screen.

https://drive.google.com/file/d/1OTiP2RxJOG3d3Yuh-OPzhRZPv2s6sklu/view?usp=sharing

  • Please use the edit link below your question to add any further information instead of adding comments. – DK Bose Jul 24 at 15:44
1

make sure no late startup jobs and autostart applications are loading, sometimes ubuntu get stuck in while starting some network and gtk applications (dhcpcd, netctl and systemctl) make sure nvidia latest or lts drivers are loaded normally, do blacklist nouveau drivers, also do some simple sanity checks. steps to override start/stop jobs:

  1. $sudo gedit /etc/systemd/system.conf
  2. change lines #DefaultTimeoutStartSec=90s #DefaultTimeoutStopSec=90s remove the pound symbol and change both 90s to 5s, after edit: DefaultTimeoutStartSec=5s DefaultTimeoutStopSec=5s
  3. finally do $sudo systemctl daemon-reload, reboot
  • no way it actually fixed it !! I have been having this issue for months tearing my hair out. Thank you so much. I honestly don't get why setting it to 5 seconds vs 90 seconds fixed it when it was at 90 I would some times wait several hours for the desktop to come up sometimes it wouldn't at all. is it bad to leave it at 5s? – zany130 Jul 25 at 0:38
  • it worked for all of yesterday I tried several reboot and shutdowns and it was fine so I turned it off and today I went to use it and it wouldn't login to my account again – zany130 Jul 27 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.