15

I am trying to install ubuntu along side with windows 10, following the official instructions given at [install ubuntu 18.04] https://vitux.com/how-to-install-ubuntu-18-04-along-with-windows-10/.

Here are screen shots of storage management (I have shrunk the D disk for installing ubuntu): enter image description here the boot-up menu:

enter image description here and installation problem (NO EFI System Partition was Found): enter image description here

1
  • 1
    Do you have a GPT disc or MBR? Jul 17 '19 at 12:18
23

yes that's correct, when you customize your own partitions like you have done here you should create a small partition just for efi. So go back and create a partition in a size of 256MB and select efi as mount point.

You can read more about recommended partitions here https://help.ubuntu.com/community/DiskSpace

4
  • I tried your suggest and then successfully installed Ubuntu. But I after rebooting, the login window only shows up the option for Ubuntu, not Windows for some reason. Do you have any idea of that? Thanks ahead
    – jingweimo
    May 19 '19 at 18:15
  • 1
    You can only have one ESP - efi system partition per drive. Best to have all drives as gpt and include the ESP as first partition, even if just data now. Then you can install to that drive later without major restructuring. Ubuntu's installer only wants to install grub to first drive, usually sda or first NVMe drive. Boot-Repair may let you do a full reinstall of grub to sdb. I found work around during install if you do not have sda with ESP. bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1396379
    – oldfred
    May 19 '19 at 18:37
  • It seems I need to remove Ubuntu and reinstall it?
    – jingweimo
    May 19 '19 at 19:03
  • 1
    I found one way to log into windows: press F2 and select windows boot manager
    – jingweimo
    May 19 '19 at 19:14
2

Your first partition is FAT32 by format, but you must pick EFI System Partition in the "right click→use as…" Dialog. (which of course implies FAT32, but not the other way round)

enter image description here

2
  • What if i don't have the "EFI System Partition" option in the dropdown?
    – joash
    Apr 7 at 20:50
  • 1
    @joash Then you better check your BIOS thoroughly to enable (U)EFI. (PCs with non-EFI-support are prehistoric by now. Probably 10 years+++) Maybe do repartioning again from scratch (botoing into live Linux 20,x comes with a gparted nowadays)... Apr 9 at 20:32
0

I had the same issue. Try changing the size of the RAM allocation (SWAP). The size of this partition should be at least equal to the size of system RAM.

1
  • 2
    Fresh installations of Ubuntu 18.04 do not have a swap partition by default. Instead they have a swap file.
    – karel
    Aug 1 '19 at 7:37
0

first of go into the hard disk drive's /boot/efi folder and rename the file grubx64.efi to mmx64.efi or other formats.

Reboot the machine and it should work.

This time when you are installing create a partition around 256MB and choose primary and EFI system partition. I hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.