0

In my current instance of Ubuntu 18.04 LTS, I have a bug of not having the English Intl with Dead Keys option in the Language packages (in my VM it actually does appear) and I haven't been able to find it anywhere, be it from the + sign or any other advanced settings.

The steps I took to encounter this problem were:

Go to the Region and Language Settings, press the + sign, click on English (US) (I've also tried it with other English countries), choose English (US, intl. with dead keys).

Is there a way of reinstalling the English language package that includes the Dead Keys options for sure?

6
  • There is no English language pack which provides keyboard layouts. The layouts are provided by the xkb-data package. But I suspect that you misunderstand the GUI somehow. Please edit your question and explain step by step how you reached the conclusion that your desired layout isn't there. – Gunnar Hjalmarsson May 18 '19 at 19:32
  • Go to the Region and Language Settings, press the + sign, click on English (US) (I've also tried it with other English countries), choose English (US, intl. with dead keys). – Philippe Fanaro May 18 '19 at 19:39
  • Just did. That way I successfully added it to the list of available keyboard layouts. Not sure what the problem is. Don't you know how to switch to it, so it becomes the layout in use? help.ubuntu.com/stable/ubuntu-help/keyboard-layouts.html – Gunnar Hjalmarsson May 18 '19 at 19:53
  • I'm not 100% sure your solution will work all the time, but it worked for me. If you wish, you can add a normal answer and I will grant you the points. – Philippe Fanaro May 20 '19 at 11:37
  • Which problem did I solve? ;) If you figured it out, I would suggest that you submit an answer yourself. It's perfectly fine to answer your own question. Then, in a couple of days, you'll be able to approve it. – Gunnar Hjalmarsson May 20 '19 at 12:10
0

As @Gunnar Hjalmarsson mentioned, you can add hidden layouts by using:

gsettings set org.gnome.desktop.input-sources show-all-sources

which comes from this Ubuntu Help Page. After executing that command on a terminal, hopefully, the layout should appear for you.

2
  • Hmm.. English (US, intl., with dead keys) is a widely used layout which should be available whether show-all-sources is enabled or not. I suspect that it was a co-incidence that it started to work for you after you had run that command. – Gunnar Hjalmarsson May 20 '19 at 21:06
  • Maybe... I don't know. We will have to wait for someone to have the same issue and have a different outcome. – Philippe Fanaro May 21 '19 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.