0

Yesterday I booted up Ubuntu 18.04, only to find out that the resolution is extremely low and the system lags a lot, it even glitches out a bit sometimes. I've tried rebooting several times with no luck. I'm running on a 1920x1080 144hz monitor and RTX 2060 with the 415.27 driver installed. The CPU is i7 8700K if that's relevant at all.

There wasn't any problem with the GPU/driver previously and the system ran smoothly on the highest graphics settings. The only change I made to the system that I could recall is installing the no-IP DDNS dynamic update client, which I hardly think would be the culprit. I also force shut down two times before the problem occurred.

P.S. I have Ubuntu installed alongside Windows 10 and the latter appears to be fine and unaffected.

  • Reinstall Nvidia drivers. – GabrielaGarcia May 20 at 14:44
  • Thank you, that worked. – fieryslug May 30 at 16:36
0

The forced shutdowns likely corrupted something in the system, affecting the Nvidia graphics drivers.

Knowing the system was working before, in this case simply reinstalling the Nvidia drivers was enough to regain functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.