0

I wanted to test out the use of a proprietary driver and used the tool "Additional drivers" for this. After this, it was a slippery slope down.

The option which was selected at the time all was fine was: Using X.Org X server -- Nouveau display driver from xserver-xorg-video-nouveau (open source)

and I switched to Using NVIDIA driver metapackage from nvidia-driver-418 (proprietary, tested)

After reboot, my resolution was down to 1024x768 (native resolution 1920x1200 using Display Port). It's the only option the "Displays" tool is showing.

Googling brought me to xrandr related posts like How to set the monitor to its native resolution which is not listed in the resolutions list?

Unfortunately my output to this command is

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00* 

and

$ xrandr --prop
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
    _MUTTER_PRESENTATION_OUTPUT: 0 
    non-desktop: 0 
        supported: 0, 1
   1024x768      76.00* 

Since the output type cannot be determined, I suspected something wrong in the driver installation and followed (the manual installation) https://medium.com/@iamdibakardipu/how-i-fixed-my-display-resolution-by-installing-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux-489563052f6c using NVIDIA-Linux-x86_64-430.14.run downloaded from NVIDIA. Installation worked out, but the issue persisted. Furthermore I noticed something odd: The blacklisting of the driver gave me the regular UI-login and not the TTY one mentioned in the article.

Since I suspected a driver issue then, I reverted to using the X.Org driver using the "Additional Drivers" tool. But there was no way back - the issue persists still with the previously working driver leaving me puzzled what this driver installation destroyed on my system.

I've also tried reconfiguring the graphics as suggested in https://ubuntuforums.org/showthread.php?t=1655348&p=10293140#post10293140

and try to

sudo killall Xorg

and trying the xandr steps from the beginning. After restarting, it seems I even managed to lock me out of the "Additional Drivers" GUI (no other option selectable).

Here are some system info in case of need:

$lspci
[...]
01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
[...]
$ glxinfo | grep "OpenGL core profile version string" 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.0.2
$ lsb_release -a 
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.04
Release:    19.04
Codename:   disco

Do you have any idea how I can get back to my native resolution? Any help is greatly appreciated and sorry for the long text.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.