0

I installed qemu using apt and got version 2.11. Decided to use a more recent version and downloaded the source for 4.0. Removed apt version with a:

apt remove qemu

successfully compiled version 4.0, but running "--version" results in version 2.11:

$ qemu-system-x86_64 --version
QEMU emulator version 2.11.1(Debian 1:2.11+dfsg-1ubuntu7.13)
Copyright (c) 2003-2017 Fabrice Bellard and the QEMU Project developers

have I removed it wrongly? will I have to compile it again? It took so much time...

0

Qemu packaging is split up into many pieces for better dependency management. The system emulation binaries are in qemu-system-x86. So if you want to get rid of that binary this is the package to remove.

You can always check which package a binary belongs to with dpkg:

$ dpkg -S qemu-system-x86_64
qemu-kvm: /usr/bin/qemu-system-x86_64-spice
qemu-system-x86: /usr/bin/qemu-system-x86_64
  • ah excuse me, I don't want to just get hid of Qemu I want my shell to execute version 4.0.0 that a I recently installed – Leo Zerino May 20 '19 at 22:28
0

As I'm new to compiling programs, I didn't know I had to make install after make to put the binaries in /bin.

After running it, I got the 4.0.0 version in my $PATH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.