2

I have a dell xps 15 9560 with a nvidia GTX 1050 and I have a problem trying to make work the nvidia drivers 430 (the recommended by ubuntu-drivers) on ubuntu 18.04 using gnome on Xorg under the kernel 5.1.x .

I have already tried executing sudo apt purge nvidia-*, rebooting and installing it both by sudo apt install nvidia-driver-430 or sudo ubuntu-drivers install and on rebooting the Settings > About panel keeps saying I'm using the intel HD 630 graphic card, also nvidia-smi states that there's no nvidia grpahic card running or no nvidia-driver installed.

I have these grub commands:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_rev_override=1 nouveau.modeset=0 nouveau.runpm=0 noresume intel_pstate=skylake_hwp"

grep -rnw /lib/modprobe.d/ -e "nvidia" gives me the next results:

/lib/modprobe.d/nvidia-kms.conf:1:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:3:options nvidia-drm modeset=1
/lib/modprobe.d/blacklist-nvidia.conf:2:# This file was generated by nvidia-prime
/lib/modprobe.d/blacklist-nvidia.conf:3:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:4:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:5:blacklist nvidia-modeset
/lib/modprobe.d/blacklist-nvidia.conf:6:alias nvidia off
/lib/modprobe.d/blacklist-nvidia.conf:7:alias nvidia-drm off
/lib/modprobe.d/blacklist-nvidia.conf:8:alias nvidia-modeset off

I had no problems using kernel 5.0 and using nvidia drivers 418, but on trying to return back to 5.0 it stopped working (I could boot, but ubuntu didn't detect any nvidia running).

I ran out of ideas (apart from reinstalling the whole OS) so I hope someone can help me diagnose what changed and make it work again...

Thanks!

Update 1: As asked, here are the outputs: mokutil --sb-state

SecureBoot disabled

test -d /sys/firmware/efi && echo efi || echo "Legacy(bios)"

efi

echo $XDG_SESSION_TYPE

x11

dkms status

nvidia, 418.56, 5.0.12-050012-generic, x86_64: installed

sudo lshw -c video

  *-display UNCLAIMED       
       description: 3D controller
       product: GP107M [GeForce GTX 1050 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:ec000000-ecffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:ed000000-ed07ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:132 memory:eb000000-ebffffff memory:80000000-8fffffff ioport:f000(size=64) memory:c0000-dffff

lsmod | grep nvidia (returned empty)


lspci -knn | grep -A 3 -E "(VGA|3D|Display)"

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
    Subsystem: Dell Device [1028:07be]
    Kernel driver in use: i915
    Kernel modules: i915
--
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
    Subsystem: Dell GP107M [GeForce GTX 1050 Mobile] [1028:07be]
    Kernel modules: nvidiafb, nouveau
02:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)

Also, prime-select query returns nvidia.

Thanks!

Update 2: As counseled by @Marmayogi, the /lib/modprobe.d/blacklist-nvidia.conf contains the following:

# Do not modify
# This file was generated by nvidia-prime
blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
alias nvidia off
alias nvidia-drm off
alias nvidia-modeset off

Update 3: As asked, the results of the commands are:

dkms status

nvidia, 430.09, 5.0.0-050000-generic, x86_64: installed
nvidia, 430.09, 5.1.3-050103-generic, x86_64: installed

uname -r

5.1.3-050103-generic

ls -al /etc/boot

ls: cannot access '/etc/boot': No such file or directory

dpkg -l *nvidia* | grep ii

ii  libnvidia-cfg1-430:amd64         430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-418             418.56-0ubuntu0~gpu18.04.1 all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-430             430.09-0ubuntu0~gpu18.04.1 all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-430:amd64      430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA libcompute package
ii  libnvidia-compute-430:i386       430.09-0ubuntu0~gpu18.04.1 i386         NVIDIA libcompute package
ii  libnvidia-decode-430:amd64       430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-430:i386        430.09-0ubuntu0~gpu18.04.1 i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-430:amd64       430.09-0ubuntu0~gpu18.04.1 amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-430:i386        430.09-0ubuntu0~gpu18.04.1 i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-430:amd64         430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-430:i386          430.09-0ubuntu0~gpu18.04.1 i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-430:amd64           430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-430:i386            430.09-0ubuntu0~gpu18.04.1 i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-430:amd64         430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-430:i386          430.09-0ubuntu0~gpu18.04.1 i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-430         430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA compute utilities
ii  nvidia-dkms-430                  430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA DKMS package
ii  nvidia-driver-430                430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-430         430.09-0ubuntu0~gpu18.04.1 amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-430         430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA kernel source package
ii  nvidia-prime                     0.8.8.2                    all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                  418.56-0ubuntu0~gpu18.04.1 amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-430                 430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA driver support binaries
ii  xserver-xorg-video-nvidia-430    430.09-0ubuntu0~gpu18.04.1 amd64        NVIDIA binary Xorg driver

ls -al ~/.local/share/gnome-shell/extensions

total 12
drwxrwxr-x 3 quimere quimere 4096 ene 22 08:02 .
drwx------ 3 quimere quimere 4096 may 18 23:46 ..
drwxrwxr-x 3 quimere quimere 4096 ene 22 08:02 user-theme@gnome-shell-extensions.gcampax.github.com
  • Why is ` Nvidia` blacklisted? – Marmayogi May 18 at 2:03
  • Please edit your question and post output of the following commands: 1. mokutil --sb-state 2. test -d /sys/firmware/efi && echo efi || echo "Legacy(bios)" 3. echo $XDG_SESSION_TYPE 4. dkms status 5. sudo lshw -c video 6. lsmod | grep nvidia and 7. lspci -knn | grep -A 3 -E "(VGA|3D|Display)" – Marmayogi May 18 at 2:07
  • @Marmayogi Not sure, shouldn't be blacklisted in any file, specially considering I prime-select query returns nvidia. I have updated the answer, thanks! – quimere May 18 at 7:24
  • Nivida-418 is installed as indicated by dkms command output but driver is not loaded in kernel (refer lspci command output). Command lshw outputs *-display UNCLAIMED and did not show the presence of Nvidia driver. Please look into /lib/modprobe.d/blacklist-nvidia.conf file and check whether Nvidia is blacklisted or not. Please report. Thanks. – Marmayogi May 18 at 10:16
  • 1
    sudo dkms remove the current Nvidia dkms driver on kernel 5.0.12, remove non-standard kernels 5.0.12 and 5.1, and go back to the standard kernel 5.0.0.-xx. Reinstall Nvidia 430 (make sure you don't have the beta version) or 418, and it should all work again. – heynnema May 18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.