0

I am attempting to overwrite Windows and install Linux on a Lenovo S340 15 inch laptop. Ubuntu, Fedora, and Mint all boot off of USB when the BIOS has secure boot turned off. The mouse and ethernet work fine. However, the installer(s) do not see the disk. The running Linuxes do not see the disk. The BIOS does not appear to have any of the dialogs discussed in other Q/A posts. In particular, I see nothing associated with the disk (SSD). Has anyone else figured this out?

(I do not want to dual boot. I increasingly loath Windows 10 and have no need for it.)

  • Did you create the disk with UEFI mode support? – fmo May 17 '19 at 14:06
2

Solved! The S340 has Intel Optane memory that the Ubuntu loader does not understand. F2 while booting to get to the Lenovo Setup Utility. Go to Configuration, then Storage and set the controller to AHCI mode. Of course you will want to disable secure boot and in the boot menu enable USB boot under UEFI.

Anyone know how to reclaim the 16 gig Optane memory? Maybe as swap???

  • Do you have optane module installed in your system. So far i have heard linux does not support optane memory. If you have not then it's pretty good not install now until Linux have the support for it. – xpioneer Sep 29 '19 at 9:38
1

JBryan's answer works fine, but has the problem that once you set the disk controller to AHCI mode directly from BIOS you will no longer be able to boot into the (pre) installed Win10.

If you intend to dual boot Win10 and linux, the best way would be to do the Intel Rapid Storage Technology to AHCI switch while booting in safe mode as explained here.

I am posting this from a linux dual booted such a way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.