0

WOL doesn't work on a fresh installation of Lubuntu 19.04

/etc/netplan/01-network-manager-all.yaml contains:

# Let NetworkManager manage all devices on this system                                                         
network:                                                                                                       
  version: 2                                                                                                   
  renderer: NetworkManager

/etc/default/halt contains:

NETDOWN=no

/etc/default/tlp contains: WOL_DISABLE=N

ethtool enp3s0 produces:

Supports Wake-on: pumbg
    Wake-on: g

But after I shut the system down, WOL doesn't work.

Problem can't be in hardware or BIOS, because there's a Lubuntu 18.04 system on the same hard drive, and with this WOL works fine.

Can anyone see what I've missed?

0

This works:

network:
  version: 2
  renderer: {renderer}
  ethernets:
    {networkname}:
      match:
        macaddress: {mac address}
     wakeonlan: true

and it is a lot more lines than you have in your yaml file. Looks like macadress is mandatory/adviced for WOL.

See also the Common properties for physical device types.

  • Thanks: I've seen something similar elsewhere, but my yaml file is what the installer created - I haven't touched it. If I tried this, how would I know what to use for "renderer" and "networkname"? – Gordon Hay May 18 at 8:02
  • OK, I've now tried that, leaving renderer as NetworkManager and including my details for interface name and mac address. But WOL still doesn't work with 19.04 (and it still does with the 18.04 system on the same hard drive. Any further hints will be most welcome... – Gordon Hay May 27 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.