I have a Wi-Fi adapter Wi-Fi adapter Realtek RTL8192CU. However, I am getting very slow speed, like ~0,5 mbit.

How do I solve the issue?


There's no need to install any drivers from GitHub (it won't work).

The problem is that the system has two drivers. (rtl8xxxu and rtl8192cu) Old one (rtl8192cu) should be turned off to turn on a new one (rtl8xxxu) that is already built into the Linux kernel.

Let's see it:

lsmod | grep rtl

Let's blacklist the last one:

sudo -i 
modprobe -r rtl8192cu
echo "blacklist rtl8192cu"  >>  /etc/modprobe.d/blacklist.conf

Then restart your system:

sudo reboot
  • FWIW, this worked perfectly for me on Linux Mint (makes sense; derived from Ubuntu). Didn't work on Solus (because a necessary kernel config parameter was missing) or Manjaro (for reasons I never understood). And while the GitHub repo that I think was referenced above (github.com/pvaret/rtl8192cu-fixes) may not be directly useful (it's deprecated), the README is worth a look for anyone with this problem.
    – jbosch
    Oct 11 '19 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.