3

WPS office doesn't seem to use window decorations.

Instead, there are integrated minimize, maximize, and close buttons at the top right corner of the (frame-less?) window. Resizing the WPS windows is extremely challenging, because the windows seem to be borderless.

Is it possible to force WPS office to launch inside a native window frame?

Additional Details:

I don't expect the integrated window controls (shown in the picture below) to go away, but I would like to have a proper title bar with native window controls.

enter image description here

  • Please mention your OS and version and how you installed WPS Office. – DK Bose May 17 '19 at 4:47
1

This works for me on openSUSE, but it's a KDE thing: Go to System Settings => Workspace => Window Management => Window Rules.

Click New.

Write whatever description you want, like "fix writer titlebar". Window class is "wps" but that's just for writer, not the whole suite.

Then on Appearance & Fixes tab, check the first item "No titlebar and frame" - change it to Force - and leave it as No because the double negatve really means to add the titlebar.

Do the same three more times, but the window classes are et, wpp, and wpspdf.

You;ll get titlebar and with it the right-click menu, and a bit wider frame to help with resizing, but you double up on the minimize, maximize, and close buttons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.