Terminal won't input password when I/it asks for it.

I am trying to install wine through terminal. Enter still works and it goes to next line to run a command as administrator (user "root"), by using the sudo command. See "man sudo_root" for details.

d@d-Dimension-8400:~$ `sudo apt-get install wine`  

[sudo] password for d: Sorry, try again.   
[sudo] password for d: Sorry, try again.   
[sudo] password for d: Sorry, try again.      

sudo: 3 incorrect password attempts  



Unix and Linux do not show your password in/within terminal while typing it for security reasons!! Basically you would see an asterisk * for each character, but not in this case!

Try to install sudo apt-get install wine again and when you are prompted for your password, simple type it in, then hit enter.

If that doesn't work out for you, then either your password is wrong, the spelling (capital letter etc..) does not match correctly or you use different passwords for login and terminal?!

  • Thanks v2r , im doing that but its still not accepting , Id assume its the password i use for logging on and when i try and install updates and software from the software center – danny keating Mar 20 '12 at 0:58
  • The little text bar isnt moving when i type the password in .Not sure if it should or not – danny keating Mar 20 '12 at 1:08
  • Sorry for the multiple texts , How would you find out if your terminal password is different from your log in? – danny keating Mar 20 '12 at 1:24
  • 1
    Got it working Thanks , I just reset the user password using passwd d – danny keating Mar 20 '12 at 1:42
  • You are very welcome Danny and sorry i didn't reply to your last question, about resetting the password earlier. Glad it worked out for you in the end!! (: – v2r Mar 20 '12 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.