1

I'm sorry I'm not sure how to handled this. I am having this problem, the question has already been asked but not answered.
I'm not sure how to revive an old message without asking the question again. If there is a better way please let me know. But I really need this resolved.

Disable battery critically low message Gnome 3

3 Answers 3

1

I've found a solution to my problem. I have permanently stopped the upower service. Since my battery is fried I don't think I need this service running.

To do this I ran systemctl stop upower. After running that command I went into the /lib/systemd/system directory and renamed upower.service to upower.service.bak.

Btw, systemctl disable upower did not work for me, the service restarted itself shortly after I ran that.

3
  • I suspect disable didn't work as intended because you left out the --now flag. The default is "on next reboot". With the --now flag, disable will also stop the service. The manual renaming is a hack, and might cause configuration problems in other services.
    – MSalters
    May 20, 2019 at 14:07
  • I tried disable --now that did not work, disable and reboot did not work either. What I did works for me, if someone has a more elegant solution I'm definitely open to it.
    – Ray_Write
    May 20, 2019 at 15:31
  • Thank you for posting the answer after the question! Renaming did solve the issue while other methods mentioned in numerous other answers on askubuntu sadly didn't help.
    – nnovich-OK
    Jan 1 at 16:22
0

If you prefer a GUI method, can use Dconf Editor to search for and edit the following keys.

Otherwise, on the command line, execute the following. (In this example, I've set everything to zero, but you can use different values, if you like).

# The percentage of the battery when it is considered low.
gsettings set org.gnome.settings-daemon.plugins.power percentage-low 0

# The percentage of the battery when it is considered critical.
gsettings set org.gnome.settings-daemon.plugins.power percentage-critical 0

# The percentage of the battery when the critical action is performed.
gsettings set org.gnome.settings-daemon.plugins.power percentage-action 0


# The time remaining in seconds of the battery when it is considered low.
gsettings set org.gnome.settings-daemon.plugins.power time-low 0

# The time remaining in seconds of the battery when it is considered critical.
gsettings set org.gnome.settings-daemon.plugins.power time-critical 0

# The time remaining in seconds of the battery when critical action is taken.
gsettings set org.gnome.settings-daemon.plugins.power time-action 0

By the way, you can set if Gnome uses battery remaining (in percentage) or time (in seconds) to notify you. The settings above will cover both cases. If the following value is set to false, percentage is used; the default is true, which means Gnome will use time to notify you.

# If time based notifications should be used.
gsettings set org.gnome.settings-daemon.plugins.power use-time-for-policy true
3
  • I just re-ready your question and updated the answer to include the settings for the "critical" notification.
    – Enterprise
    May 17, 2019 at 2:55
  • Unfortunately that did not work for me.
    – Ray_Write
    May 18, 2019 at 16:21
  • The only other thing I could suggest is to change the last command above to gsettings set org.gnome.settings-daemon.plugins.power use-time-for-policy false to tell Gnome to use the % power remaining (instead of time remaining) to apply the notification settings.
    – Enterprise
    May 18, 2019 at 21:03
0

renamed upower.service to upower.service.bak

This is the only solution that worked for me. The command systemctl disable upower does actually work to disable the systemd service, but there are other parts of the GNOME power management system which will still restart upower even when the systemd service has been disabled. (Remember that you can still start a service using systemctl start even when the service is disabled using systemctl disable. The disabling just means that it won't automatically start by itself when the system (re)boots.)

Yes, manual renaming is a hack, but I would argue that it's still less of a hack than, say, doing a dpkg -r --force-depends upower.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.