So at first I was unable to get my Belkin Surf & Share usb to install on my computer, so then I plugged my computer directly into my router and my computer won't acknowledge any connection. I know very little about how to use ubuntu, please help me. What I do know is:

  • I'm using Ubuntu 10.04 Lucid Lynx
  • In my 'edit connections', I go into 'wired' tab, select "wired connection 1" then 'edit' it brings up 4 tab options:

    • Wired (I input the MAC address that's printed on the bottom of my router, MTU is set to automatic)
    • 802.1x Security (currently: not checked)
    • IPv4 Settings (currently: Automatic (DHCP) addresses only)
    • IPv6 Settings (currently: Automatic)
  • 2
    I think your main problem is that you edited the MAC address and placed hard-coded the MAC Address of your router into the settings for your adapter. A MAC address is unique to each device. Mar 20, 2012 at 1:56

3 Answers 3


You need to ensure your router is set for DHCP which will provide your Ubuntu PC with all the information it needs, if not you should enter the details manually. If you are using just a wired connection this will resolve your issue.


click on the ipv4 tab and try changing the address type from automatic to manual. then you can enter the ip address, net mask and dns servers, manually. your network provider will be knowing ur ip address and netmask. hope this helps


I've had that problem sometimes. You should check your notification area, right click your network conection icon, and see if you have "Activate Network" and "Activate Wireless" options marked. I'm not sure why this happens, but maybe it could be of some help. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.