1

I have installed guile2.0 into /usr/dev

two makefiles (Makefile.am and Makefile.in) along with executable makefile exist in libgraph-1.0.2 after extracting and running ./configure. command ./configure doesn't appear to have any errors.

make results in error at line 34 "missing separator" code is if(GUILE) changing to if"tab"(GUILE) or if"tab"("tab"GUILE) yields same error if I change to "tab"if(GUILE) I get "recipe commences before first target".

I have tried every combination of I can think of but I always get one of the two errors and make fails.

Could someone advise a newbie on what needs to be done?

  • I'm sorry, but what was wrong with simple sudo apt-get install guile-2.0 (it is packaged). – N0rbert May 16 at 20:47
  • nothing at all..My first line says I installed guile-2.0 and is in /usr/dev – KelownaDave May 17 at 11:56
  • What do you mean by libgraph-1.0.2? From where did you downloaded it? – N0rbert May 17 at 12:12
  • Thanks for replying. Perhaps I have not been clear. I want to code (draw) simple graphic shapes in Ubuntu 18.04 using g++. However, every example I've seen uses "graphics.h" which is not included with g++. Libgraph does include"graphics,h" but so far I have been stymied trying to install libgraph. – KelownaDave 2 days ago
  • Could you please share a link to example, which uses "graphics.h"? – N0rbert 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.