0

I'm new with Ubuntu. I needed to install a Ubuntu-Server and connect with SSH. After many Problems it worked, but now i can't connect with the Internet.

sudo more /etc/resolve.conf
more stat of /etc.resolve.conf failed: no such file or directory

Everytime I start my Server, following message appears:

Failed to connect to https://changelogs.ubuntu.com/meta-release. Check your Internet connection or proxy settings

If I try to Ping www.google.de for example this happens:

sudo ping www.google.de 
ping: www.google.de: Temporary failure in name resolution

My Setting in /etc/network/interfaces are:

auto lo
iface lo inet loopback
#
auto enp0s3
iface enp0s3 inet dhcp
#
auto enp0s8
iface enp0s8 inet dhcp

And i can't Ping 8.8.8.8

sudo ping 8.8.8.8
connect: Network is unreachable

I'm thankful for every help!

New contributor
breater is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • What does more /etc/resolve.conf show? Please edit the results of that command into the question (but do feel free to remove the comments at the top we only need the nameservers. Also edit out any personal info if there is any like your outside IP) – Rinzwind May 16 at 14:33
  • added. what do you mean with personal info like outside IP? Sorry english isnt my motherlanguage, so i dont know where to find it. – breater May 16 at 15:38
  • 1
    Eh what is with the error? The line shows a dot where i expect a dash – Rinzwind May 16 at 15:51
  • 1
    @Rinzwind I think you mean /etc/resolv.conf, not /etc/resolve.conf – vidarlo May 16 at 16:01
  • Ubuntu 19.04 does not use /etc/network/interfaces. It uses netplan. – chili555 May 16 at 16:15
0

First, I suggest that you revert the faulty changes to /etc/network/interfaces. Edit the file so that it contains only:

auto lo
iface lo inet loopback

Next, rename your existing empty file:

sudo mv /etc/netplan/01-ens160.yaml /etc/netplan/01-netcfg.yaml

Next, edit the file to include your required details. I suggest:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      dhcp4: true
    enp0s8
      dhcp4: true

Netplan is very specific about spacing and indentation. Proofread carefully twice. Follow with:

sudo netplan generate
sudo netplan apply

Example yaml files are conveniently located in /usr/share/doc/netplan/examples.

Reboot.

  • I followed exactly your advice and now i can ping Websites, but when I start my Server the Message: "Failed to connect to changelogs.ubuntu.com/meta-release. Check your Internet connection or proxy settings appears. Is there anything" & my SSH-Connection doesnt work too. – breater May 17 at 8:00
  • Do both ethernet ports have an active, working connection, or just one. We ought to remove the lines for the inactive interface. How do you ssh to a DHCP server? Or shall I amend my answer to propse a static IP? – chili555 May 17 at 11:32
  • God bless you man, internet is working now! I try to connect via SSH with MobaXTerm to the enp0s3-IP shown when i type "ip addr" it Says: 192.168.77.3/24 brd 192.168.77.255. I connected yesterday with 192.168.77.3 and it worked. And today he says: "no connection" – breater May 17 at 16:08
  • Since the address is dynamic, is it perhaps no longer xx.3. Check: ip addr show – chili555 May 17 at 18:56
  • It's as describes above: the enp0s3 -ip is 192.168.77.3/24. But no connection via SSH to this IP. – breater yesterday

Your Answer

breater is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.