1

I am running a standard Ubuntu 18.04.

$lsb_release -a
LSB Version:    core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:    18.04
Codename:   bionic

But I am lacking hyperthreading.... It's 100% enabled in the BIOS. I disabled and enabled it just to check whether the problem was there, but it's not... However cpuinfo says: core : 4, siblings : 4, while it should be siblings : 8...

https://ark.intel.com/content/www/us/en/ark/products/88196/intel-core-i7-6700-processor-8m-cache-up-to-4-00-ghz.html

I don't remember when this happened in my desktop... maybe since the upgrade from 16.04 to 18.04.

I am pasting the lscpu.

$lscpu 
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  1
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               94
Model name:          Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
Stepping:            3
CPU MHz:             800.001
CPU max MHz:         4000.0000
CPU min MHz:         800.0000
BogoMIPS:            6816.00
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            8192K
NUMA node0 CPU(s):   0-3
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp md_clear flush_l1d

I tried to disable secure boot with mokutil, as suggested, and I got

$sudo mokutil --disable-validation
EFI variables are not supported on this system

So I checked the installation with lsblk

$lsblk 
NAME    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda       8:0    0 119.2G  0 disk  
├─sda1    8:1    0   487M  0 part  /boot/efi
├─sda2    8:2    0     5M  0 part  
├─sda3    8:3    0  46.6G  0 part  /
└─sda4    8:4    0  72.2G  0 part  
sdb       8:16   0 931.5G  0 disk  
├─sdb1    8:17   0   9.3G  0 part  [SWAP]
├─sdb2    8:18   0   7.2G  0 part  /var
├─sdb3    8:19   0  18.6G  0 part  /tmp
└─sdb4    8:20   0 896.4G  0 part  
  └─md0   9:0    0 896.2G  0 raid1 /home
sdc       8:32   0 931.5G  0 disk  
└─sdc1    8:33   0 896.4G  0 part  
  └─md0   9:0    0 896.2G  0 raid1 /home

So now, I am more than stuck... Any suggestion is welcome, thanks,

Alessandro

  • 1
    What is the output of lscpu? – singrium May 16 at 12:30
  • I pasted the output of lscpu in the question. Thanks :-) – Alex May 17 at 13:08
  • This is weird, Thread(s) per core: 1 says that whether thread is not enabled or your CPU does not support threading, which is illogical according to Intel website. Are you shure you enabled the threading from the BIOS menu? if yes, try to disable secure boot from the BIOS menu and check it again. – singrium May 17 at 13:44
  • In the bios the hyperthreading is enabled 1000%. I would say that at also secure boot is disabled, otherwhise it would not have been possible to install several packages (e.g. virtualbox). As soon as I reboot the pc I'll double check. Thanks! – Alex May 17 at 14:32
  • Also check this discussion in Reddit, it may be useful. – singrium May 17 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.