1

I am new to Ubuntu (to Linux in general) and while I was installing Latex through the terminal:

sudo apt-get install texlive-full

I had this error message:

E: Unable to correct problems, you have held broken packages.

and the full result of the previous command is:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 texlive-full : Depends: asymptote but it is not going to be installed
                Depends: biber but it is not going to be installed
                Depends: cm-super (>= 0.3.3-3) but it is not going to be installed
                Depends: context but it is not going to be installed
                Depends: dvipng but it is not going to be installed
                Depends: feynmf but it is not going to be installed
                Depends: fragmaster but it is not going to be installed
                Depends: latex-cjk-all (>= 4.6.0+cvs20060714-2) but it is not going to be installed
                Depends: latexmk but it is not going to be installed
                Depends: lmodern (>= 0.93.3) but it is not installable
                Depends: prerex (> 6.5.3-1) but it is not going to be installed
                Depends: purifyeps but it is not going to be installed
                Depends: tex-gyre but it is not going to be installed
                Depends: texinfo (>= 4.8)
                Depends: texlive-base (>= 2018.20190227) but it is not installable
                Depends: texlive-bibtex-extra (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-binaries (>= 2018.20180416) but it is not installable
                Depends: texlive-extra-utils (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-font-utils (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-fonts-extra (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-fonts-extra-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-fonts-extra-links (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-fonts-recommended (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-fonts-recommended-doc (>= 2018.20190227) but it is not installable
                Depends: texlive-formats-extra (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-games (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-humanities (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-humanities-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-arabic (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-chinese (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-cjk (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-cyrillic (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-czechslovak (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-english (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-european (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-french (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-german (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-greek (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-italian (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-japanese (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-korean (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-other (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-polish (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-portuguese (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-lang-spanish (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-latex-base (>= 2018.20190227) but it is not installable
                Depends: texlive-latex-base-doc (>= 2018.20190227) but it is not installable
                Depends: texlive-latex-extra (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-latex-extra-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-latex-recommended (>= 2018.20190227) but it is not installable
                Depends: texlive-latex-recommended-doc (>= 2018.20190227) but it is not installable
                Depends: texlive-luatex (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-metapost (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-metapost-doc (>= 2018.20190227) but it is not installable
                Depends: texlive-music (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-pictures (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-pictures-doc (>= 2018.20190227) but it is not installable
                Depends: texlive-plain-generic (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-pstricks (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-pstricks-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-publishers (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-publishers-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-science (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-science-doc (>= 2018.20190227) but it is not going to be installed
                Depends: texlive-xetex (>= 2018.20190227) but it is not going to be installed
                Depends: tipa (>= 2:1.2-2.1) but it is not going to be installed
                Depends: vprerex (> 6.5.3-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Remark: When I was installing Latex in the first time it was going well, then I lost my connexion and stopped the task, so when I went to it the second time the problem began.

EDIT: I was trying to see what is there in the two comments, for the first one, the problem seems to don't be about the universe repository, because when I made this command

sudo add-apt-repository universe

I have got

'universe' distribution component is already enabled for all sources.

for the second comment, I have tried all that was written in the answers, but no one seems to be working with me, for example

dpkg --get-selections | grep hold

give nothing, updating, upgrading and making autoremove and so also did,' solve the problem, I have also installed synaptic, but in it, there is nothing in the broken part, I am really lost with this problem, thanks in advance

marked as duplicate by N0rbert, karel, Kulfy, Fabby, Eric Carvalho May 18 at 21:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.