0

I am a newbie to ubuntu. I was trying to install tlp, so I entered the following commands:

sudo add-apt-repository ppa:linrunner/tlp
sudo apt update
sudo apt upgrade

and the terminal is now stuck at 70% for a long time. A screenshot of the terminal.

What should I do in this case? Is it safe to force stop it?
Thanks

Terminal full output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-4.15.0-50 linux-headers-4.15.0-50-generic
  linux-headers-4.18.0-20 linux-headers-4.18.0-20-generic
  linux-image-4.15.0-50-generic linux-image-4.18.0-20-generic
  linux-modules-4.15.0-50-generic linux-modules-4.18.0-20-generic
  linux-modules-extra-4.15.0-50-generic linux-modules-extra-4.18.0-20-generic
The following packages will be upgraded:
  cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon
  cups-ipp-utils cups-ppdc cups-server-common libcups2 libcupscgi1
  libcupsimage2 libcupsmime1 libcupsppdc1 linux-generic
  linux-generic-hwe-18.04 linux-headers-generic
  linux-headers-generic-hwe-18.04 linux-image-generic
  linux-image-generic-hwe-18.04 linux-libc-dev linux-signed-generic-hwe-18.04
22 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 134 MB of archives.
After this operation, 660 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-ipp-utils amd64 2.2.7-1ubuntu2.5 [210 kB]
Get:2 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupscgi1 amd64 2.2.7-1ubuntu2.5 [27,4 kB]
Get:3 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-core-drivers amd64 2.2.7-1ubuntu2.5 [27,8 kB]
Get:4 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupsmime1 amd64 2.2.7-1ubuntu2.5 [13,2 kB]
Get:5 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-server-common all 2.2.7-1ubuntu2.5 [415 kB]
Get:6 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupsimage2 amd64 2.2.7-1ubuntu2.5 [18,6 kB]
Get:7 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupsppdc1 amd64 2.2.7-1ubuntu2.5 [45,0 kB]
Get:8 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-common all 2.2.7-1ubuntu2.5 [206 kB]
Get:9 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-ppdc amd64 2.2.7-1ubuntu2.5 [26,8 kB]
Get:10 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-bsd amd64 2.2.7-1ubuntu2.5 [38,4 kB]
Get:11 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-client amd64 2.2.7-1ubuntu2.5 [139 kB]
Get:12 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups-daemon amd64 2.2.7-1ubuntu2.5 [296 kB]
Get:13 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcups2 amd64 2.2.7-1ubuntu2.5 [211 kB]
Get:14 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 cups amd64 2.2.7-1ubuntu2.5 [191 kB]
Get:15 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-modules-4.15.0-50-generic amd64 4.15.0-50.54 [13,0 MB]
Get:16 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-image-4.15.0-50-generic amd64 4.15.0-50.54 [7.917 kB]
Get:17 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-modules-extra-4.15.0-50-generic amd64 4.15.0-50.54 [32,7 MB]
Get:18 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-generic amd64 4.15.0.50.52 [1.864 B]
Get:19 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-image-generic amd64 4.15.0.50.52 [2.512 B]
Get:20 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.15.0-50 all 4.15.0-50.54 [11,0 MB]
Get:21 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.15.0-50-generic amd64 4.15.0-50.54 [1.113 kB]
Get:22 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-generic amd64 4.15.0.50.52 [2.472 B]
Get:23 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-modules-4.18.0-20-generic amd64 4.18.0-20.21~18.04.1 [13,3 MB]
Get:24 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-image-4.18.0-20-generic amd64 4.18.0-20.21~18.04.1 [8.160 kB]
Get:25 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-modules-extra-4.18.0-20-generic amd64 4.18.0-20.21~18.04.1 [32,2 MB]
Get:26 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-generic-hwe-18.04 amd64 4.18.0.20.70 [1.876 B]
Get:27 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-image-generic-hwe-18.04 amd64 4.18.0.20.70 [2.532 B]
Get:28 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.18.0-20 all 4.18.0-20.21~18.04.1 [10,5 MB]
Get:29 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-4.18.0-20-generic amd64 4.18.0-20.21~18.04.1 [1.105 kB]
Get:30 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-headers-generic-hwe-18.04 amd64 4.18.0.20.70 [2.488 B]
Get:31 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-libc-dev amd64 4.15.0-50.54 [1.007 kB]
Get:32 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-signed-generic-hwe-18.04 amd64 4.18.0.20.70 [1.904 B]
Fetched 134 MB in 39s (3.449 kB/s)                                             
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 264444 files and directories currently installed.)
Preparing to unpack .../00-cups-ipp-utils_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-ipp-utils (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../01-libcupscgi1_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking libcupscgi1:amd64 (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../02-cups-core-drivers_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-core-drivers (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../03-libcupsmime1_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking libcupsmime1:amd64 (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../04-cups-server-common_2.2.7-1ubuntu2.5_all.deb ...
Unpacking cups-server-common (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../05-libcupsimage2_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking libcupsimage2:amd64 (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../06-libcupsppdc1_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking libcupsppdc1:amd64 (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../07-cups-common_2.2.7-1ubuntu2.5_all.deb ...
Unpacking cups-common (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../08-cups-ppdc_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-ppdc (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../09-cups-bsd_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-bsd (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../10-cups-client_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-client (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../11-cups-daemon_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups-daemon (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../12-libcups2_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking libcups2:amd64 (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Preparing to unpack .../13-cups_2.2.7-1ubuntu2.5_amd64.deb ...
Unpacking cups (2.2.7-1ubuntu2.5) over (2.2.7-1ubuntu2.4) ...
Selecting previously unselected package linux-modules-4.15.0-50-generic.
Preparing to unpack .../14-linux-modules-4.15.0-50-generic_4.15.0-50.54_amd64.deb ...
Unpacking linux-modules-4.15.0-50-generic (4.15.0-50.54) ...
Selecting previously unselected package linux-image-4.15.0-50-generic.
Preparing to unpack .../15-linux-image-4.15.0-50-generic_4.15.0-50.54_amd64.deb ...
Unpacking linux-image-4.15.0-50-generic (4.15.0-50.54) ...
Selecting previously unselected package linux-modules-extra-4.15.0-50-generic.
Preparing to unpack .../16-linux-modules-extra-4.15.0-50-generic_4.15.0-50.54_amd64.deb ...
Unpacking linux-modules-extra-4.15.0-50-generic (4.15.0-50.54) ...
Preparing to unpack .../17-linux-generic_4.15.0.50.52_amd64.deb ...
Unpacking linux-generic (4.15.0.50.52) over (4.15.0.48.50) ...
Preparing to unpack .../18-linux-image-generic_4.15.0.50.52_amd64.deb ...
Unpacking linux-image-generic (4.15.0.50.52) over (4.15.0.48.50) ...
Selecting previously unselected package linux-headers-4.15.0-50.
Preparing to unpack .../19-linux-headers-4.15.0-50_4.15.0-50.54_all.deb ...
Unpacking linux-headers-4.15.0-50 (4.15.0-50.54) ...
Selecting previously unselected package linux-headers-4.15.0-50-generic.
Preparing to unpack .../20-linux-headers-4.15.0-50-generic_4.15.0-50.54_amd64.deb ...
Unpacking linux-headers-4.15.0-50-generic (4.15.0-50.54) ...
Preparing to unpack .../21-linux-headers-generic_4.15.0.50.52_amd64.deb ...
Unpacking linux-headers-generic (4.15.0.50.52) over (4.15.0.48.50) ...
Selecting previously unselected package linux-modules-4.18.0-20-generic.
Preparing to unpack .../22-linux-modules-4.18.0-20-generic_4.18.0-20.21~18.04.1_amd64.deb ...
Unpacking linux-modules-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...
Selecting previously unselected package linux-image-4.18.0-20-generic.
Preparing to unpack .../23-linux-image-4.18.0-20-generic_4.18.0-20.21~18.04.1_amd64.deb ...
Unpacking linux-image-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...
Selecting previously unselected package linux-modules-extra-4.18.0-20-generic.
Preparing to unpack .../24-linux-modules-extra-4.18.0-20-generic_4.18.0-20.21~18.04.1_amd64.deb ...
Unpacking linux-modules-extra-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...
Preparing to unpack .../25-linux-generic-hwe-18.04_4.18.0.20.70_amd64.deb ...
Unpacking linux-generic-hwe-18.04 (4.18.0.20.70) over (4.18.0.18.68) ...
Preparing to unpack .../26-linux-image-generic-hwe-18.04_4.18.0.20.70_amd64.deb ...
Unpacking linux-image-generic-hwe-18.04 (4.18.0.20.70) over (4.18.0.18.68) ...
Selecting previously unselected package linux-headers-4.18.0-20.
Preparing to unpack .../27-linux-headers-4.18.0-20_4.18.0-20.21~18.04.1_all.deb ...
Unpacking linux-headers-4.18.0-20 (4.18.0-20.21~18.04.1) ...
Selecting previously unselected package linux-headers-4.18.0-20-generic.
Preparing to unpack .../28-linux-headers-4.18.0-20-generic_4.18.0-20.21~18.04.1_amd64.deb ...
Unpacking linux-headers-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...
Preparing to unpack .../29-linux-headers-generic-hwe-18.04_4.18.0.20.70_amd64.deb ...
Unpacking linux-headers-generic-hwe-18.04 (4.18.0.20.70) over (4.18.0.18.68) ...
Preparing to unpack .../30-linux-libc-dev_4.15.0-50.54_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.15.0-50.54) over (4.15.0-48.51) ...
Preparing to unpack .../31-linux-signed-generic-hwe-18.04_4.18.0.20.70_amd64.deb ...
Unpacking linux-signed-generic-hwe-18.04 (4.18.0.20.70) over (4.18.0.18.68) ...
Processing triggers for ufw (0.36-0ubuntu0.18.04.1) ...
Setting up cups-server-common (2.2.7-1ubuntu2.5) ...
Processing triggers for ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot
Setting up cups-common (2.2.7-1ubuntu2.5) ...
Setting up linux-headers-4.18.0-20 (4.18.0-20.21~18.04.1) ...
Setting up linux-libc-dev:amd64 (4.15.0-50.54) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for systemd (237-3ubuntu10.21) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up linux-modules-4.15.0-50-generic (4.15.0-50.54) ...
Setting up linux-headers-4.15.0-50 (4.15.0-50.54) ...
Setting up linux-modules-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...
Setting up libcups2:amd64 (2.2.7-1ubuntu2.5) ...
Setting up linux-headers-4.18.0-20-generic (4.18.0-20.21~18.04.1) ...


Progress: [ 70%] [##########################################..................] ```
New contributor
M. Zidan is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

marked as duplicate by pLumo, karel, Community May 16 at 15:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Stop it then do this sudo dpkg --configure -a see if that will fix the problem. you may have to reboot also.

  • That solved it! Thank you! – M. Zidan May 16 at 15:37
0

You can do ctrl+c (which kills the current process), and press to see the command in the terminal again, then enter to repeat the command and it should work.

If not then I'd purge my local package cache and repeat the upgrade:

sudo apt clean && sudo apt update && sudo apt upgrade

(though personally I use aptitude instead of apt).

Possibly the server has a bad copy of that headers file, so you could download the same file from packages.ubuntu.com and then install it with

sudo dpkg -i /path/to/package

(replacing the path with the proper one). Once you've done that you can repeat your apt upgrade.

Not the answer you're looking for? Browse other questions tagged or ask your own question.