8

My main goal is to install Tizen Studio IDE so I can learn Tizen development, and I want to do this on Ubuntu.

I have downloaded web-ide_Tizen_Studio_3.2_ubuntu-64.bin and make it executable, and can run this (after a long struggle to install the JDK, but thats another question for another time). But when I do, it says that i have not installed the prerequisites, and I must do the following:

sudo apt-get install libwebkitgtk-1.0-0 sudo apt-get install rpm2cpio

The rmp2cpio package seemed to install, but not the libwenkitgtk-1.0-0. It gives me the error:

~/Downloads$ sudo apt-get install libwebkitgtk-1.0-0 Reading package lists... Done Building dependency tree
Reading state information... Done Package libwebkitgtk-1.0-0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libwebkitgtk-1.0-0' has no installation candidate

I have tried searching for a package but it looks like there is not one available (only for older versions of ubuntu) but there must be some way I can force it or even install the version for Ubuntu 18.04 or 18.10?

Thank you

Adam

6
  • Thanks for replying, I tried this and got: ~/Downloads$ sudo apt install libwebkitgtk Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package libwebkitgtk
    – AdMaN
    May 16, 2019 at 4:24
  • Based on this, it seems to only be available for up to 18.10. I would suggest to download the .deb file from the PPA here, by expanding version 2.4.11-4 of webkitgtk for Cosmic (18.10), and downloading libwebkitgtk-1.0-0_2.4.11-4.deb for the correct architecture. Then, use sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-4_<your architecture>.deb. You may also need to install dependencies with sudo apt install -f.
    – Eate
    May 16, 2019 at 4:33
  • Thank you very much Eate, I followed those instructions and it worked. There was a dependency for libjavascriptcoregtk-1.0-0_2.4.11-4_amd64.deb which I installed in the same manner. I was then able to install Tizen Studio. The next problem is that the package manager will not load - just click and nothing happens, and trying to run Tizen Studio (Eclipse?) gives me a very long error message. I will raise another question for this.
    – AdMaN
    May 16, 2019 at 5:00
  • Hm. This might be because it was for another version, and might have broken something — it should still work, though,
    – Eate
    May 16, 2019 at 5:29
  • I'm adding this as an answer so that the question can be answered; I'd appreciate it if you marked it as accepted. Thanks!
    – Eate
    May 16, 2019 at 5:31

2 Answers 2

3

Based on this, it seems to only be available for up to 18.10. I would suggest to download the .deb file from the PPA here, by expanding version 2.4.11-4 of webkitgtk for Cosmic (18.10), and downloading libwebkitgtk-1.0-0_2.4.11-4.deb for the correct architecture. Then, use sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-4_<your architecture>.deb. You may also need to install dependencies with sudo apt install -f.

Edit: As @fkraiem said, installing 18.04 will also solve your problems, and I personally recommend using the LTS versions unless you really want the latest version.

Install 18.04... – fkraiem

3
  • A note that this was copied from a comment on the question since this solved the issue.
    – Eate
    May 16, 2019 at 5:32
  • could you elaborate more on the steps? especially on "expanding" the version. Navigating the PPA page is very alien to me
    – Tian
    Mar 23, 2020 at 14:55
  • 1
    Click here, scroll or look down until you see a heading in the table of releases, "The Bionic Beaver (supported)". Click on the version you want (currently, 2.4.11-3ubuntu3) under "The Bionic Beaver", and scroll down to click on "libwebkitgtk-1.0-0: Web content engine library for GTK+". Click on it. Find your architecture (likely amd64) and click on the latest version that says "(Release)" (currently libwebkitgtk-1.0-0 2.4.11-3ubuntu3 in amd64 (Release) for amd64). Click and download the file under "Downloadable files". Then dpkg install.
    – Eate
    Mar 24, 2020 at 19:05
3

I am not sure this is something stupid to do, but I was running out of options and this solution solved my problem. (please tell me if I did something idiotic).

I created a bionc.list in /etc/apt/sources.list.d in than file I added the following line:

deb http://cz.archive.ubuntu.com/ubuntu bionic main universe

I ran an apt update and then installed libwebkit normally...

I needed to run Vega and this was the only way I figured to do it...

Good news - it worked... I am waiting for the bad news

1
  • 1
    This should be an accepted answer... Aug 20, 2021 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.