5

I tried to update my Ubuntu 16.04 through sudo apt-get dist-upgrade, but now the terminal is frozen (terminal 1).

I let it run for an entire day (more than 24 hours) and I just suspended the OS once.

I've already tried to follow some tips on the internet (e.g here), but to no avail unfortunately.

Some piece of codes, that I found on the internet, I'm not able to use them, because the Ubuntu says that it is locked by another process (terminal 2).

Would anyone know what could be happening? Or what could I do to solve it? Because I don't know if was failed or successed, or if it is still running, because I've already tried to type some "enter"s, however nothing happens, neither it is created a new line on the terminal, it is frozen.

Thank you in advance.

terminal 1

$ sudo apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-4.4.0-148 linux-headers-4.4.0-148-generic
  linux-image-4.4.0-148-generic linux-modules-4.4.0-148-generic
  linux-modules-extra-4.4.0-148-generic linux-tools-4.4.0-148
  linux-tools-4.4.0-148-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic linux-tools-virtual
4 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 69,1 MB of archives.
After this operation, 314 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-modules-4.4.0-148-generic amd64 4.4.0-148.174 [12,0 MB]
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-image-4.4.0-148-generic amd64 4.4.0-148.174 [6.925 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-modules-extra-4.4.0-148-generic amd64 4.4.0-148.174 [36,6 MB]
Get:4 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-generic amd64 4.4.0.148.156 [1.784 B]
Get:5 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-image-generic amd64 4.4.0.148.156 [2.750 B]
Get:6 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-headers-4.4.0-148 all 4.4.0-148.174 [9.982 kB]
Get:7 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-headers-4.4.0-148-generic amd64 4.4.0-148.174 [810 kB]
Get:8 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-headers-generic amd64 4.4.0.148.156 [2.582 B]
Get:9 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-tools-4.4.0-148 amd64 4.4.0-148.174 [2.850 kB]
Get:10 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-tools-4.4.0-148-generic amd64 4.4.0-148.174 [2.598 B]
Get:11 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-tools-virtual amd64 4.4.0.148.156 [2.610 B]
Fetched 69,1 MB in 2min 11s (526 kB/s)                                         
Selecting previously unselected package linux-modules-4.4.0-148-generic.
(Reading database ... 302549 files and directories currently installed.)
Preparing to unpack .../linux-modules-4.4.0-148-generic_4.4.0-148.174_amd64.deb ...
Unpacking linux-modules-4.4.0-148-generic (4.4.0-148.174) ...
Selecting previously unselected package linux-image-4.4.0-148-generic.
Preparing to unpack .../linux-image-4.4.0-148-generic_4.4.0-148.174_amd64.deb ...
Unpacking linux-image-4.4.0-148-generic (4.4.0-148.174) ...
Selecting previously unselected package linux-modules-extra-4.4.0-148-generic.
Preparing to unpack .../linux-modules-extra-4.4.0-148-generic_4.4.0-148.174_amd64.deb ...
Unpacking linux-modules-extra-4.4.0-148-generic (4.4.0-148.174) ...
Preparing to unpack .../linux-generic_4.4.0.148.156_amd64.deb ...
Unpacking linux-generic (4.4.0.148.156) over (4.4.0.146.154) ...
Preparing to unpack .../linux-image-generic_4.4.0.148.156_amd64.deb ...
Unpacking linux-image-generic (4.4.0.148.156) over (4.4.0.146.154) ...
Selecting previously unselected package linux-headers-4.4.0-148.
Preparing to unpack .../linux-headers-4.4.0-148_4.4.0-148.174_all.deb ...
Unpacking linux-headers-4.4.0-148 (4.4.0-148.174) ...
Selecting previously unselected package linux-headers-4.4.0-148-generic.
Preparing to unpack .../linux-headers-4.4.0-148-generic_4.4.0-148.174_amd64.deb ...
Unpacking linux-headers-4.4.0-148-generic (4.4.0-148.174) ...
Preparing to unpack .../linux-headers-generic_4.4.0.148.156_amd64.deb ...
Unpacking linux-headers-generic (4.4.0.148.156) over (4.4.0.146.154) ...
Selecting previously unselected package linux-tools-4.4.0-148.
Preparing to unpack .../linux-tools-4.4.0-148_4.4.0-148.174_amd64.deb ...
Unpacking linux-tools-4.4.0-148 (4.4.0-148.174) ...
Selecting previously unselected package linux-tools-4.4.0-148-generic.
Preparing to unpack .../linux-tools-4.4.0-148-generic_4.4.0-148.174_amd64.deb ...
Unpacking linux-tools-4.4.0-148-generic (4.4.0-148.174) ...
Preparing to unpack .../linux-tools-virtual_4.4.0.148.156_amd64.deb ...
Unpacking linux-tools-virtual (4.4.0.148.156) over (4.4.0.146.154) ...
Setting up linux-modules-4.4.0-148-generic (4.4.0-148.174) ...
Setting up linux-image-4.4.0-148-generic (4.4.0-148.174) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.4.0-146-generic
I: /initrd.img.old is now a symlink to boot/initrd.img-4.4.0-146-generic
I: /vmlinuz is now a symlink to boot/vmlinuz-4.4.0-148-generic
I: /initrd.img is now a symlink to boot/initrd.img-4.4.0-148-generic
Setting up linux-modules-extra-4.4.0-148-generic (4.4.0-148.174) ...
Setting up linux-image-generic (4.4.0.148.156) ...
Setting up linux-headers-4.4.0-148 (4.4.0-148.174) ...
Setting up linux-headers-4.4.0-148-generic (4.4.0-148.174) ...

terminal 2

$ sudo dpkg --configure --pending
dpkg: error: dpkg frontend is locked by another process

$ sudo dpkg --configure -a
dpkg: error: dpkg frontend is locked by another process

$ sudo apt -f install
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
0

Almost identical to this situation: Ubuntu 18.04 stuck at upgrading linux-header

The accepted answer there with 5 upvotes (6 now) is below


TLDR: Disable Secure Boot.

I started having this same issue about a month ago. For me it turns out the solution was disabling Secure Boot. I've had Secure Boot disabled since I installed Ubuntu 18.04 and it's upgraded without any problems. However, about a month ago, I updated my BIOS which re-enabled Secure Boot (I didn't know this at the time). It was frustrating having the upgrades freeze and I finally figured it out because my VirtualBox installation was also not working. The fix for VirtualBox was disabling Secure Boot which also fixed my linux-headers-<version>-generic upgrades.

As noted in the question, it would freeze here:

...
Setting up linux-headers-4.15.0-38-generic (4.15.0-38.41) ...

After disabling Secure Boot, I get:

...
Setting up linux-headers-4.15.0-38-generic (4.15.0-38.41) ...
/etc/kernel/header_postinst.d/dkms:
Secure Boot not enabled on this system.
...
done
0

Another more easy way to upgrade your Ubuntu version it through this command:

do-release-upgrade
0

I would like to share the steps I did to fix the problem.

First, I needed to close the terminal manually. Then, I had to remove the lock:

sudo rm /var/lib/dpkg/lock

After that, I was able to execute the following commands:

sudo dpkg --configure --pending

sudo dpkg --configure -a

sudo apt install -f

Thank you to the Linux group members that helped me to solve this question and the others that tried to help me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.