4

I did a clean install of Ubuntu 18.04 a few days ago. I've been using the terminal without any issues.

When I tried opening the terminal today, it failed to launch. I've tried launching it from the applications page as well as using the Alt+Ctrl+T keyboard shortcut.

When running gnome-terminal --verbose though Tilda terminal, get the following error:

# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

I've tried reinstalling the terminal by running sudo apt install --reinstall gnome-terminalbut no luck.

After some further reading, I found out that Chrome remote desktop can cause issues for the gnome-terminal to launch. I uninstalled it using sudo apt remove chrome-remote-desktop. The terminal launched successfully once I rebooted.

  • I am unable to open a terminal window. I've tried launching it from the applications screen as well as using the Alt + Ctrl + T – JM Nel May 15 at 20:17
  • 1
    Please try opening a terminal with Super-F2 as shown in itsfoss.com/ubuntu-shortcuts – K7AAY May 15 at 20:20
  • I've run the 'gnome-terminal' command in the Alt-F2 terminal, but there's no output. It just closes with nothing happening. – JM Nel May 15 at 20:31
  • With any available terminal, please run sudo apt update and follow that up with sudo apt full-upgrade. Tell us if you see any errors or warnings or messages you don't understand or normally see. – DK Bose May 16 at 2:13
  • Please consider title change to something like chrome breaks gnome-terminal... Thanks. – WinEunuuchs2Unix May 16 at 15:42
4

I was able to fix the issue by uninstalling Chrome remote desktop by running $ sudo apt remove chrome-remote-desktop

I found the solution on https://ubuntuforums.org/showthread.php?t=2383992

  • 2
    Glad it worked but I'm a little confused as to how it fixed the broken gnome-terminal. Was there a link you read that pointed you to this solution? – WinEunuuchs2Unix May 16 at 15:40
2

First, try reinstalling gnome-terminal:

sudo apt update
sudo apt install --reinstall gnome-terminal

Next, run the following command to run gnome-terminal in verbose mode to see if there is any output:

gnome-terminal --verbose 

If all else fails you can install xfce4-terminal instead:

sudo apt update
sudo apt install xfce4-terminal

Then, you can set xfce-terminal as the default terminal to start on CTRL+ALT+T by first running the following command:

sudo update-alternatives --config x-terminal-emulator

Then, select the number for xfce4-terminal and then press ENTER

You should now be able to run xfce4-terminal by pressing CTRL+ALT+T

source

1

Try reinstalling the terminal app by going into Ubuntu Software. Terminal Emulator should be listed in the Installed TAB. Press Remove and after a while install it again in the All TAB.

  • I am not able to remove or uninstall the terminal from the Ubuntu software app. – JM Nel May 15 at 20:30
  • That is because you are no admin. Install Synaptic with the same Ubuntu software app and launch that. It will have you log in and be admin. Synaptic is like Ubuntu software a tool to install and manage software and you will be amazed how much more software it shows. With synaptic you can reinstall terminal and install any other there is. – Marc May 15 at 21:55
  • @Marc It is probably a dependency issue preventing the uninstall. See the following command to list all packages which depend on gnome-terminal: apt-cache rdepends gnome-terminal | grep -P '^ [a-z].*$' – mchid May 15 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.