0

Recently I've upgraded my Ubuntu from 18.04 LTS to 18.10. This also upgraded my PHP 7.1 to this version: PHP 7.1.28-1+ubuntu18.04.1+deb.sury.org+3. Now I have to downgrade to PHP 7.1.27 due to 7.1.28 introducing some breaking changes and causing my Symfony project not to work.

I've been struggling with this downgrade with no success. Seems that there's nothing below that version available:

 $ apt-cache policy php7.1               
 php7.1:
   Installed: 7.1.28-1+ubuntu18.04.1+deb.sury.org+3
   Candidate: 7.1.29-1+ubuntu18.10.1+deb.sury.org+1
   Version table:
      7.1.29-1+ubuntu18.10.1+deb.sury.org+1 500
         500 http://ppa.launchpad.net/ondrej/php/ubuntu cosmic/main amd64 Packages
         500 http://ppa.launchpad.net/ondrej/php/ubuntu cosmic/main i386 Packages
  *** 7.1.28-1+ubuntu18.04.1+deb.sury.org+3 100
         100 /var/lib/dpkg/status


 $ apt-cache madison php7.1
     php7.1 | 7.1.29-1+ubuntu18.10.1+deb.sury.org+1 | http://ppa.launchpad.net/ondrej/php/ubuntu cosmic/main amd64 Packages
     php7.1 | 7.1.29-1+ubuntu18.10.1+deb.sury.org+1 | http://ppa.launchpad.net/ondrej/php/ubuntu cosmic/main i386 Packages


$ apt-cache showpkg php7.1                                    
Package: php7.1
Versions: 
7.1.29-1+ubuntu18.10.1+deb.sury.org+1 (/var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_binary-amd64_Packages) (/var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_binary-i386_Packages)
 Description Language: 
             File: /var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_binary-amd64_Packages
              MD5: 86488d7a405bdcbac9ece7c307f30abb
 Description Language: en
             File: /var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_i18n_Translation-en
              MD5: 86488d7a405bdcbac9ece7c307f30abb
 Description Language: 
             File: /var/lib/dpkg/status
              MD5: 86488d7a405bdcbac9ece7c307f30abb

7.1.28-1+ubuntu18.04.1+deb.sury.org+3 (/var/lib/dpkg/status)
 Description Language: 
             File: /var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_binary-amd64_Packages
              MD5: 86488d7a405bdcbac9ece7c307f30abb
 Description Language: en
             File: /var/lib/apt/lists/ppa.launchpad.net_ondrej_php_ubuntu_dists_cosmic_main_i18n_Translation-en
              MD5: 86488d7a405bdcbac9ece7c307f30abb
 Description Language: 
             File: /var/lib/dpkg/status
              MD5: 86488d7a405bdcbac9ece7c307f30abb


Reverse Depends: 
Dependencies: 
7.1.29-1+ubuntu18.10.1+deb.sury.org+1 - libapache2-mod-php7.1 (16 (null)) php7.1-fpm (16 (null)) php7.1-cgi (0 (null)) php7.1-common (0 (null)) 
7.1.28-1+ubuntu18.04.1+deb.sury.org+3 - libapache2-mod-php7.1 (16 (null)) php7.1-fpm (16 (null)) php7.1-cgi (0 (null)) php7.1-common (0 (null)) 
Provides: 
7.1.29-1+ubuntu18.10.1+deb.sury.org+1 - php (= ) 
7.1.28-1+ubuntu18.04.1+deb.sury.org+3 - php (= ) 
Reverse Provides:

So how do I downgrade it? It doesn't have to be strictly 7.1.27, but anything lower than 7.1.28 will do.

  • Not easily possible, unless 7.0 is fine. – fkraiem May 15 at 7:07
  • @fkraiem Unfortunately not, minimum requirement is 7.1. – XploD May 15 at 8:03
  • 2
    Well then basically you're on your own. Lesson learned: don't use PPAs if you need stability; they are inherently unstable. – fkraiem May 15 at 8:13
  • Have you considered solving the problem by modifying Symfony? – Jos May 15 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.