I just purchased a Canon Pixma MP495. It was working perfect, except for the scanner. It won't install the driver for the scanner.

Anyway, I was printing using the new printer. After a while, it started saying that the printing job was sent to the printer and then that the print job was completed. But, nothing came out of the printer. I uninstalled the driver and installed it over again. Nothing. Can somebody help me out. Can't work without a printer. Thanks in advance.


Not sure this will be any help but are you running 11.10 or 12.04? In 12.04 my printer (canon mg5130) just stopped working and I spent like 2 hours trying to reinstall the drivers ... finally I uninstalled the drivers and tried the system settings> Printers > add printer ... and it installed that way which was the first time that ever happened ... Now it prints fine ... in fact it has more functions such as Print test page which never worked before ...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.