0

This is problem on HP laptop which has 2 video controllers.

By using prime-select you can choose Intel or Nvidia. If you choose "prime-select intel", then xgamma working, but you are using low speed video controller.
If you choose "prime-select nvidia" then xgamma not working, but you are using high speed.
On the same laptop in Windows even if you use Nvidia, you still can open Intel panel and change gamma settings separately.

Does anyone knows a way to fix configure gamma when prime profile is Nvidia?

  • Have you checked the option in Nvidia X Server Settings? And I doubt that in Windows when running with Nvidia the settings in Intel panel had much of an effect while still running with the same Nvida card (they would after changing to Intel). – GabrielaGarcia May 14 at 19:20
  • Nvidia has not such option, no in Windows, not in Linux. On my laptop 2D always rendered in Intel, Nvidia renders only 3D – richman1000000d May 16 at 15:59
  • i.stack.imgur.com/Gj5rg.png Isn't this what you're looking for? – GabrielaGarcia May 16 at 16:05
  • No, there is no such option in nvidia settings. No in Windows either – richman1000000d May 16 at 16:07
  • I'm showing you a picture of the Nvidia X Server Settings. Is yours different? – GabrielaGarcia May 16 at 16:08
0

I fond it!!!

this command will give you display name

xrandr

and then this command change it gamma!!

xrandr --output Display --gamma 1:1:1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.