tl;dr- Added conky to xscreensaver. Doesn't show up on lock screen, but shows up on desktop.

I'm trying to create my own screensaver by adding my Conky configuration to xscreensaver. I read the following page: How to get conky work even in lock screen?

My issue is that after I've added conky to xscreensaver, my lock screen/preview is blank, but when I'm messing with the settings, conky appears on my desktop. I followed the first link to set this up on my laptop (running Xubuntu 18.04) and now I'm trying to set this up on my desktop (also running Xubuntu 18.04).

The link says to add the following line to ~/.xscreensaver:

"Conky"  conky -q --window-id=$XSCREENSAVER_WINDOW -c ~/.conkyrc-screensaver \n\

When I set this up on my laptop, the variable $XSCREENSAVER_WINDOW is not set and specifying the rc file prevented the screensaver from running. Thus, this is the command I added:

"Conky" conky -q \n\

Where I simply made the default rc file the one I wanted for my screensaver. Thus, my specific question is how do I get conky to show up on the lockscreen?

I also read this page (Conky (or other apps) on Gnome-screensaver unlock screen), but as I'm using xfce and trying to avoid using Gnome, I don't think this is the way to go either.

I recorded starting/selecting the screensaver and uploaded the video here. The main thing I am demonstrating is that my conky setup starts as soon as it is selected by xscreensaver. I also tried recording the screensaver/preview, but all it showed was a black screen.

2nd Edit: I disabled one of my monitors and my conky configuration appears with the screensaver now! I'm guessing that conky and xscreensaver are both working correctly and I have something messed up with my monitor configuration.


I figured out my problem. I needed to comment out the following line in my conky config:

own_window_type = 'normal'

Once I did this, my lock screen shows the clock (on one of my screens).

I'm including links to my config file and lua script if anyone is interested: .conkyrc_screensaver


You should add the command, as described. When you run xscreensaver &, it will spawn shells to run the commands it is told, and $XSCREENSAVER_WINDOW will be available to the script/command at that time.

It makes it a bit harder to debug, but give it a shot as described in the instructions and see if that is helpful. Also, be sure that you select this new screensaver as your screensaver, most easily using xscreensaver-command -demo, and disable randomization or changing to different screensavers.

  • I did end up trying again using the --window-id option and specifying the rc file, but my conky config is still showing up on my desktop and not my lock-screen. I did end up excluding the -q quiet option and I can see some of the output on my lock screen, but nothing else. I will try again tomorrow with xscreensaver-command -demo – pwesterbaan May 15 '19 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.