3

I'm getting this while installing anaconda on ubuntu 19.04 Im getting this while installing anaconda on ubuntu 19.04

  • make sure you have root permission. type in terminal command su - and it will ask you root password and then try to install. – JackyChan May 14 '19 at 12:46
  • 3
    @JackyChan: anaconda does not need root priviledges when installed in the home directory of a user. – Thomas May 14 '19 at 13:32
  • Did you upgrade anaconda or just did a fresh install? Maybe nothing has to be done by ` conda init? It looks like the conda` environment is set up already. Does conda activate <environment> work? – Thomas May 14 '19 at 13:35
  • I think you done everything. Then just run the command anaconda-navigator in terminal – Ganesh Kanna Sep 7 '19 at 14:53
  • Please copy and paste logs in text (or type in), do not post an image for text output. – 0xc0de Nov 20 '19 at 12:52
2

Try By Using anaconda-navigator:

activate conda:

$ source ~/anaconda3/bin/activate root

Launch conda:

$ anaconda-navigator

If you want to launch JupyterNotebook simply run

jupyter notebook
| improve this answer | |
  • This works for me – Marie Jan 23 at 19:42
1

While this does not try to fix this problem, rather helps as a workaround when I want to activate an env.

$ source ~/anaconda3/bin/activate <env_name>
| improve this answer | |
0

As far as I understand this, conda init [shell] is used to initiate a specific shell utilized when executing command-line conda commands. Not specifying one will default it to bash, which I'm guessing is what you already use here—since this is the output.

More information can be found by using the [-h] flag:

$ conda init -h
| improve this answer | |
0

I had the same problem. Previously I had anaconda 2 but I removed to install anaconda 3. After installing anaconda 3 and using conda init I got the same error message, as I solved it. Enter your .bashrc:

gedit ~/.bashrc

Identify the following lines in the .bashrc file and delete them:

# >>> conda initialize >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup = "$ ('/ home / spidey / anaconda3 / bin / conda' 'shell.bash' 
'hook' 2> / dev / null)"
if [$? -eq 0]; then
    eval "$ __ conda_setup"
else
    if [-f "/home/spidey/anaconda3/etc/profile.d/conda.sh"]; then
        . "/home/spidey/anaconda3/etc/profile.d/conda.sh"
    else
        export PATH = "/ home / spidey / anaconda3 / bin: $ PATH"
    fi
fi
unset __conda_setup
# <<< conda initialize <<<

Explanation:
Since previously you already had an anaconda installation, the conda init command did not modify anything because it detected that you had already made changes to the .bashrc file.

| improve this answer | |
0

Use this instead:

conda activate
jupyter notebook
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.