2

I just upgraded the packages on my 18.04 machine and after reboot I see a new symbol in my top right that looks like a shield with a red "denied" symbol on it. enter image description here

After further investigation this turns out to be the icon for the "livepatch" feature. It is notifying me that "livepatch" is off, and urges me to register to enable it.

I have zero interest in livepatch. I never opted to install this feature. I guess if I don't do something this shield will stay annoying and in-my-face 24/7-365?

Anyway I need help to remove it permanently like it never existed in the first place. Like completely deleted from my OS. Any help is much appreciated.

EDIT-1: Clarification in case you think I want to simply hide the notification. I actually want to COMPLETELY OBLITERATE IT and leave behind only unlinked inodes.

EDIT-2: I don't have livepatch installed. In fact look at this screenshot: enter image description here

  • 2
    I vote this to not be a duplicate because I don't want to hide it. I want (as is clearly stated in the question) to completely remove it. – Lennart Rolland May 13 '19 at 16:08
  • You can uninstall livepatch using sudo snap remove canonical-livepatch – Kulfy May 13 '19 at 16:10
  • @Kulfy: Thanks! However I don't have livepatch installed. I added a screenshot to question! – Lennart Rolland May 13 '19 at 16:13
  • 3
    Perhaps you have it but not as a snap, do you have /usr/lib/systemd/user/update-notifier-livepatch.service. It seems that you must have /usr/lib/update-notifier/livepatch-notification? Perhaps sudo ubuntu-advantage disable-livepatch -r is what you seek (from that apps man page). – pbhj May 13 '19 at 16:17
  • 4
    Possible duplicate of Hide livepatch indicator in top panel – PenguinCSC May 19 '19 at 17:35
0

It may be that you don't have livepatch installed as clarified in the question but the gnome top bar icon is still showing, here is the solution:

Run this command in terminal to remove the livepatch icon in the top bar in Ubuntu.

gsettings set com.ubuntu.update-notifier show-livepatch-status-icon false

In comments I read that livepatch may not be a snap package but by default livepatch snap package is installed in Ubuntu, I haven't found any non-snap package of livepatch. But, I suggest you keep livepatch in the system as it installs and applies critical Linux kernel security updates without rebooting your system.

Source 1

Source 2

  • Didn't work for me; see comments on askubuntu.com/a/1140850/568304 for details. – Murphy Jun 12 '19 at 14:19
  • @Murphy I'm guessing the patch fixed it? – Flimm Jun 19 '19 at 7:36
  • Yep, after a full-upgrade and a reboot the issue was fixed, don't know why it occurred in the first place. – FutureJJ Jun 19 '19 at 9:35
  • @Flimm For me the issue isn't fixed yet, though the installed version is supposed to be the right one. – Murphy Jun 20 '19 at 6:55
0

You can also use dconf-editor to remove the Livepatch notification icon.

If you don't have it,

sudo apt install dconf-editor
  1. Open dconf-editor.
  2. Go to 'com > ubuntu > update-notifier > show-livepatch-status-icon' (or just start typing "livepatch" after opening dconf-editor).
  3. You have an on/off switch for the notification icon.

This disables (or enables) the notification icon. It does not remove or turns off Livepatch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.