0

I am trying to install ubuntu 16.04 alongside Windows 10. I used rufus to make the usb as bootable. The partition scheme it automatically selected is MBR. I successfully completed this step.

After the restart of the system and selecting the USB to boot, I got the below error:

enter image description here

Now I have read most of the questions related to this issue but there are few things which are not clear. I have checked the Windows BIOS mode and it says Legacy mode and because the USB installer is trying to install in UEFI mode and thus its showing this error. Do we need to make bootable usb in Legacy mode to pass this error. How can we do this.? I did not see any option for this in rufus. Is there any other software I can use to make the bootable usb in Legacy mode. Please help. Thanks.

  • You should install both OSes in UEFI mode, especially Windows. Any preinstalled Windows 8 or newer is in UEFI mode. – GabrielaGarcia May 13 at 13:31
  • @GabrielaGarcia Dont know why it says Legacy Bios mode. I am checking it through win+r and then msinfo32. Is there any other way to check.? Can UEFI mode be disabled somewhere in BIOS settings. Can I enable it back.? – S Andrew May 13 at 13:33
  • UEFI is not BIOS, it replaced it many years ago. Legacy is what emulates BIOS and only useful for installing legacy OSes that don't support UEFI. The default firmware (UEFI, wrongly still called "BIOS" by many people and entities) settings for most motherboards allows both modes "UEFI+Legacy/CSM" so user's either disable legacy mode or they have to make sure they're booting the installer (Windows or Linux) in UEFI mode. That was the case if you noticed 2 entries/options for your USB stick, one with UEFI in the name, one without. – GabrielaGarcia May 13 at 13:44
  • 1
    If drive is MBR(msdos) partitioned then Windows is BIOS boot only. Difficult to convert. If an upgrade from Windows 7 or user installed it may be BIOS boot with MBR. Difficult to convert Windows without full backup & reinstall & restore data. You cannot have UEFI & BIOS on same drive as Windows has to have boot flag on its NTFS bootable partition and UEFI requires boot flag on ESP - efi system partition (FAT32). And you cannot have two boot flags. Post this: sudo parted -l – oldfred May 13 at 13:47
  • 1
    How you boot install media, UEFI or BIOS is how it installs. And that on many systems is independent of default boot settings in UEFI/BIOS. You normally get two entries for booting a flash drive, typically UEFI:flash or flash, where flash is name or label of flash drive, mine just says PMAP. And one that is just flash name is BIOS boot. – oldfred May 13 at 13:49
0

I was able to solve this issue.

In BIOS settings, under startup, I selected BOTH (enabling UEFI and Legacy) and under preference, I selected UEFI first.

After this, I was able to install the ubuntu fine.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.