0

I boot my laptop today as usual and this error appeared:

relocation 0x0 is not implemented yet
Aborted. press any key to exit

Then it went into windows boot manager after pressing any key. I'm using Ubuntu 19.04 on Asus FX504GD, dual boot with Windows 10. I googled and found that this is a Grub error and seems to be related to rescue mode, but I found no solution. I couldn't think of any thing that I have done recently to cause this error. A detailed instruction (e.g. making required cammands explicit) will be greatly appreciated for a newbie like me. Thank you.

  • Can you reach GRUB menu by pressing shift key while restart? If so, do you observe Windows 10 and Ubuntu boot loaders there? Please reply. Thanks. – Marmayogi May 13 at 2:09
  • @Marmayogi pressed shift while restart and entered windows advanced boot menu. After pressing Use a device, there are both windows boot manager and Ubuntu, but that seems to be equivalent to pressing ESC while booting, which result in the same error while selecting Ubuntu. – Frank Wang May 13 at 2:39
  • Restart your system and press shift or esc key to enter into GRUB menu. Use Up/Dn arrows to select Ubuntu and then press e. A screen will appear, and look for the line linux. Use Up/Dn arrows and reach that line. Press end key to reach end of line containing linux. Now type a space character followed by 3. Press Ctrl+X to boot. You will be taken to terminal TTY and there you enter your login username and password. – Marmayogi May 13 at 2:57
  • (continue from previous comment....) Please run commands sudo apt-get update, sudo apt-get upgrade and sudo apt-get dist-upgrade. Now you issue command sudo update-grub. Finally type reboot. After rebooting reach GRUB menu by pressing shift or esc key and try to boot by selecting ubuntu. Please report. Thanks. – Marmayogi May 13 at 2:57
  • @Marmayogi Thank you for your help. But I cannot enter GRUB menu. When I select Ubuntu in the boot menu (by pressing ESC when booting) it shows the error mentioned in the main post. The same thing happens if I don't press anything as it boot into GRUB by default. Therefore, I don't know how to issue the command you have mentioned. – Frank Wang May 13 at 3:03
0

I'm answering my own question (even though this is a bit stupid) since I just found a solution myself and I want to share it to help others.

I entered live system with a live usb and tried grub repair tool following this instruction. Then, I can boot into my system correctly even though a few new options appear in my grub menu. Still not sure what caused the problem. Please tell me if you have any idea.

Thanks to @Marmayogi for helping me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.